RM500Q-AE firmware

I have an RM500Q-AE running firmware version RM500QAEAAR11A01M4G. When using 5G NSA modes, I get occasional disconnects and Transmit queue timeout failures. Using LTE modes, I haven’t seen the failure, but I can’t ever get carrier aggregation working. Carrier aggregation works if I use an EP06-A modem, so it seems likely related to the modem. Is there a newer firmware that might solve some of these issues?

Dear Jons,
Nice to know you!Yes ,we have newer firmware, you can contact our sales or distributor to get it. thanks. By the way, in order to better support you, could you help to answer below questions?

  • Company name and located city:

  • Project name (so we can refer to it in the future):

  • Application type:

  • Estimated Annual Units (for series production):

  • Project timeline:

  • Current status:

  • From which distributor do you buy Quectel modules & EVB kits?

  • Do you have EVB kit for this application?

I replied with these answers in a DM.

I’m also looking for firmware. RM500QGLAB-M20-SGASA Q1-A6646.

I have both emailed and tried to chat with zero response. A bit odd that there’s not easy access to this.

  • Company name and located city: contractor
  • Project name (so we can refer to it in the future): testing
  • Application type: testing
  • Estimated Annual Units (for series production): n/a
  • Project timeline: < 90 days
  • Current status: looking for current firmware
  • From which distributor do you buy Quectel modules & EVB kits? - varies
  • Do you have EVB kit for this application? - n/a

Hello Sir
RM500QGLAB-M20-SGASA Q1-A6646 you sent are not firmware version name, they are ordering code and PN information, if you want to buy, we can send our local sales contact way to you, thanks!

I realize that. RM500QGLAB-M20-SGASA Q1-A6646 is the model of the modem I am testing with.

How can I quickly get firmware for this modem?

Hello Sir,
Did you have RM500Q-AE in you hand now? if yes, you can send the ATI command to inquiry about the firmware version, if you just do the test personally, the latest firmware version is not a necessary requirement.By the way, could you provide your company name and your based country?Thanks!

Thanks Peter. The current firmware installed is…

RM500QGLABR10A02M4G_01.001.01.001

Also, to clarify - this is a RM500Q-GL, not AE. Figured this would be clear since I included the full model number, but you asked if I have this “RM500Q-AE in you hand right now”, so just wanted to make sure we’re on the same page.

Hello Sir,
I saw that the topic is about RM500Q-AE firmware, anyway,RM500QGLABR10A02M4G is not the latest firmware. But if you just do the test personally, the latest firmware version is not a necessary requirement.By the way, could you provide your company name and your based country? Thanks again!

What is the latest firmware?

There are a couple of issues I’m troubleshooting and I want to make sure they’re not related to outdated firmware.

I’m a contractor based in the US.

Look forward to your response.

Hello Sir,
already send you a mail, please check it ,thanks!

Peter,

Am I able to get the latest firmware for the rm500q-ae?

Thank you

Hello Peter,

I believe that I answered the questions you asked in a PM I sent earlier. My current firmware using the ATI command shows: RM500QAEAAR11A02M4G

Hello John,
I remember it now, I have connected you with our NA technical and sales team as you can see in the mail, and RM500QAEAAR11A02M4G is the latest firmware. If you have other questions in the future, please discuss with them in mail, thanks!

Thank you Peter for all your help

Hi all,

I was wondering if you can help with a request regarding the n77 support of the Quectel RM505Q-AE. Specifically, there is some firmware blocking the connectivity and I was wondering if there is a previous version of the firmware that allows n77 connection to be established successfully.

Many thanks in advance : )

Dear Alex,
we support n77 SA. what problem do you have, how do you test, what is the current firmware version of your module, you can send ATI command to get it.Thanks.