RM 500Q GL No Power over USB


I am working on a data collection project with the RM500Q-GL Board. But I cannot get it started over USB (J401) or over the external power supply (J801). The red status led just won’t light up. I tried it over PCIe there it worked as expected. But since I need to move around for the data collection process it is no option for me to run the board in my dektop pc but only with my laptop. I checked the user guide and found out about the S104 switch, which is supposed to be (or become?) the pcie/usb switch. I tried every possible state of the two switches but it still won’t start over USB. Any idea what I could be doing wrong?

Best regards

Louis Andrée

Dear @louis.andree
Could you share the picture of your board?

Hi silvia, Sure let me know If you need any parts in Detail.

best regards


Dear @louis.andree
I have the board on my side, it worked fine after I turned the two button. Could you confirm the USB port of your PC has enough power supply for this EVB? Maybe you can try to connect other USB port or connect a power adapter through J104. It seems the power supply didn’t enough.

Dear @silvia,

I already tried different USB ports, different cables and also tried connecting an external power supply. I used a similar board last year it caused no problems. Is it possible that the firmware could be the problem?

Dear @louis.andree
It didn’t seem to related with firmware, your power LED didn’t light, it is strange, please check your power supply.

I am using a 5V 2A AC Adapter. It should work right? Also I have a second module that works fine with the same USB cable and power supply. So if the power supply is fine and it’s no firmware issue, means my hardware is broken right?

Dear @louis.andree
I tried without module on my side, if power supply is ok, power LED will light. Did you have any other board or module to cross check?

Yeah I tried another Module with same usb cable and port and it worked.