RG500Q-GL connect to 5G testing network

Hello everyone!

I have problems connecting to our testing 5G SA network with a Quectel modem (further details about my setup are below).

I’m using standard drivers included in kernel and ModemManager (mmcli).

This is the procedure I use:

  • connect the modem to USB, start ModemManager
  • enable the modem: mmcli -m 0 --enable
  • connect the modem: mmcli -m 0 --simple-connect=“apn=’’”

The last step timeouts in my case.
After some time, the SIM card shows as registered in the modem details and even the bearer shows up, but it’s not initialized properly (see the bearer.txt).

When I try to connect to our 5G net with the same SIM card using a different modem (OVM FritzBox), the connection is established.
Also, when I follow the same steps above with a SIM card of a public operator (Telekom in Germany) and try to register to their 4G network, the connection is also established.

Could anybody tell me, if there is something wrong in this approach? Are there any extra steps needed in order to connect to a testing 5G network with Quectel? Is this the whole thing meant to work without the qmi_wwan_q driver at all? I’d be glad for any help.

Thanks,
Franky.

PS: Apparently, I can’t attach the ZIP to my topic, so I uploaded it to transfernow instead: Herunterladen - TransferNow

System:
x86_64 machine, Arch Linux, kernel 5.16 (standard qmi_wwan and option driver. I haven’t compiled anything provided from quectel (like qmi_wwan_q))
ModemManager 1.18
qmicli 1.30

Modem info: modem.txt in the attached zip
Bearer info: bearer.txt in the attached zip
Further details:

  • at+cops?
    +COPS: 0,0,“999 01”,11
  • at+qeng=“servingcell”
    +QENG: “servingcell”,“NOCONN”,“NR5G-SA”,“TDD”, 999,01,2,1,1,647232,78,12,-67,-11,27,1,-
  • at+qcfg=“usbnet”
    +QCFG: “usbnet”,0
  • at+c5greg?
    C5GREG: 0,1

qmicli info: qmicli.txt in the attached zip

  1. Add APN and try again.
    image
  2. if it doesn’t work, use qmi_wwan_q.c driver.

Hi Isaac,
thank you for your answers!
ad 1: Unless I am missing something, this is the very same command I shared in my question, which unfortunately didn’t work.
ad 2: About qmi_wwan_q.c: the file that we received on the flash drive with our modem is very old and incompatible with recent linux kernels. It can’t be compiled. Is there a newer version of the qmi_wwan_q driver compatible with kernel 5.11?
Thank you.

I means you should add the specific APN name.
eg:
mmcli -m 0 --simple-connect=“apn=cmnet’’

1 Like

Hi Isaac,

thanks for your responses. In the end, there was likely a problem with the testing network. Now everything works well with the mmcli and --simple-connect.
Let’s consider this question resolved.

Cheers,
Franky.

1 Like

Ok, you are welcome!