Reading I2C returns a empty bytearray

Hi, I’m trying to get sensor data from a sensor connected to a UMTS&LTE EVBs J804 i2c pins. All i get back is a empty array. Any idea on what the problem could be? We are using the bg95-m3 module.

QuecPython code can be found in the link below. (1.8 KB)

Any help is highly appreciated!



May i ask which firmware version are you using?

I tested with the latest firmware and I2C worked fine

My firmware version is QPY_OCPU_V0001_BG95M3_FW

I have downloaded the latest version (V001) from the download zone, when I run modem.getDevFwVersion() I get following response

Yes,this is the latest firmware and the issue should not be kernel-related.

But I do not have the corresponding I2C slave. Let me take a look at the datasheet to make sure there are no other problems with the configuration.

I’ve changed the register address to bytearray(0x00) since the slave doesn’t have a specified register address.

Yes, the register address needs to be changed to 0x00.
Can the module read the value after the register address is changed to 0?

I recommend that you can print the return value of the read/write function to confirm that the return is normal

I’ve done that, both read and write returns 0.

Could you grab a waveform with the oscilloscope?

Let’s analyze the waveform

Please try this script to check if the module can read the data (1.5 KB)

I made basically those changes earlier. Turned out that the main issue I had left was on the hardware side, now that I moved the sensor and resistors to a breadboard everything is working as it should.

Thank you for your time!