Quectel RM520N-GL N78 band aggregation

Hello! I am writing from Kazakhstan, my modem is Quectel RM520N-GL. My base station issues 3_N78C, other routers (ZTE, Huawei) and the phone work in such aggregation and speeds reach up to 1 Gbit, and Quectel RM520N-GL only works with 3C_N78 and speeds are only 270 Mbit. The modem was used in conjunction with Mikrotik RBM and OpenWRT (USB3.0 everywhere and additional power supply). Can you help?

Thanks in advance!

Dear @tesk019
Please test with the latest firnware.
RM520N-GL support the ENDC as below:

Good afternoon Thanks for your response! From the factory there was RM520NGLAAR01A07M4G_01.201.01.201, then I installed RM520NGLAAR03A03M4G_01.200.01.200 and RM520NGLAAR03A02M4GA. I downloaded the firmware from Github. What is the latest firmware now? I tried the AT+QPRTPARA=1 command once, but it didn’t help. Will the AT+QPRTPARA=3 command help in this case, and how harmful is it for the modem? Our providers sell branded routers ZTE MC889 and Huawei H155-380, maybe they limit them by device? What if I try the command AT+EGMR=1.7 and enter the numbers from the smartphone?

@tesk019, I have seen the firmware RM520NGLAAR03A02M4GA, probably on the github you reference. I was unsure however if this firmware is for the standard RM520-GL-AA module given the _A reference in the firmware information PDF. Can you confirm RM520NGLAAR03A02M4GA worked with your module and that you are also able to flash back for example to RM520NGLAAR03A03M4G_01.200.01.200?


The latest firmware didn’t solve the problem either. This is how the Huawei 5G CPE works when the router is located in the house, and the RM520N works using

outdoor antennas.

The modem did not work stably with this firmware. Link downs.

Are there any solutions to my issue? I used the “AT+EGMR=1,7,“xxxx”” command, thinking that the provider was limiting the speed on the device, but it didn’t help.