Quectel RG520N-EU driver for Ubuntu 22.04 (kernel 6.5.0-28-generic)?

Hello Folks,

I have Ubuntu 22.04.4 LTS version i need to install the quectel software/drive for the RG520N-EU modem! Where can I find this driver? My kernel version is kernel 6.5.0-28-generic.

Thanks in advance.

The Linux kernel driver include 2 parts.
For usbserial please it is the option driver. The source code is in the Linux kernel and you just need to add the VID & PID into the option_ids.
For the usbnet, you can try the qmi_wwan_q I just sent.

Quectel_Linux_Android_QMI_WWAN_Driver_V1.2.7.zip (801.4 KB)
Quectel_QConnectManager_Linux_V1.6.5.1.zip (219.7 KB)
Quectel_QConnectManager_Linux_User_Guide_V1.0.pdf (315.1 KB)

Hello,

Thank you for your support!
I tried to install qmi_wwan_q, but it didn’t work. The error triggers:

"“The kernel was built by: x86_64-linux-gnu-gcc-12 (Ubuntu 12.3.0-1ubuntu1~22.04) 12.3.0”

Attached I puted my screenshoot of dmesg result and the error log. Can you help to solve this issue, please? Are there any videos of this configuration procedure?

Thanks in advance.



sudo apt install gcc-12 build-essential

It worked! Thank you.

Now, I can successfully connect in a 5G SA network.

I need to extract signal quality data from the network. However, when I open the serial connection with the quectel module and enter the AT commands, there is no response in the terminal. Could you help me, please?

Best,

Actually it is because that the Ubuntu use the ModemManager to set up data call.
And the ModemManager will use all the ttyUSB of the Quectel modem.

For my suggestion, you can disable the ModemManager and try the quectel-CM to set up data call.
And you can send AT also.

How to handle carrier disconnections? - Technical Subjects / Driver - Quectel Forums

Hello,

I turned off the linux gui option Mobile Broadbrand. After that, I installed and executed quectel-CM tool (image attached), but my usb ports still remain blocked and I can’t use AT commands.

How can I successfully disable ModemManager?

sudo systemctl stop ModemManager
sudo systemctl disable ModemManager