Quectel EM120K-GL GPS function not working on Raspberry Pi 4

Hi, I have successfully made my quectel modem work with a raspberrypi 4 using rasp os or balena os.
The problem I have is when I try to make the GPS work. When the HAT is connected to a windows machine (powered via USB) and I use QCOM to send the AT commands to activate the GPS


The modem outputs the latitude and longitude with no issues.

But when I connect the Modem via USB to the pi (the modem was installed and tried with an external power source and via USB) the modem never gets a fixed. I run

minicom -D /dev/ttyUSB2

when in Minicom I run


and I get this error:


The modem is detected by my raspberry and i can use it for internet connection.

Bus 002 Device 004: ID 2c7c:030b Quectel Wireless Solutions Co., Ltd. EM120K-GL
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Can anyone help me troubleshooting the issue please?