Quectel EM120 on Lenovo P14S device manager error 3 Generic Mobile broadband adapter

Hi there

I’m new here. I have a big problem: my laptop is Lenovo P14s, version with Quectel EM120 LTE modem embedded.

It worked like a charm. Problem is that today i launched “Lenovo Commercial Vantage” and it found a new “critical update” Quectel EM120 WWAN software update version
I installed the update as always.

When i rebooted in device manager i found a Generic Mobile Broadband Adapter with yellow mark that substituted the Quectel Device.

If i click on it i have "error 37 - unable to find object name. I tried to uninstall the device and to install the package downloaded from Lenovo Website but problem is still here.

I’m desperate, please help me!

Hardware ID of my Quectel LTE is:

I searched this VID online but i’m unable to find a stand alone driver package

Thank you so much

Could you take a photo of the module and show the IMEI on it?
There are many different EM120x…
Which Driver have you tried?
Could you the device manager?
Windows 10, is it?

Hello and thank you for your support!

Here is the thread i opened on Lenovo Forum:

The Quectel WWAN “bricked” after Lenovo Vantage package Quectel driver update. I think package was the same installed before when the Quectel board worked well but after the update the system installed a Generic Broadband Device signed by Microsoft with error code 37 and can’t find any Quectel driver even if i try to install it manually!

Do you think the brick is reversible? I read on lenovo forum the Quectel and Lenovo are preparing a rescue firmware package for a similar problem (eSim unrecognized)

However you can find more details on the thread i linked on Lenovo forum

Thank you so much!

I will send the driver please try it.

Can you show the module and the device manager on the Windows?

Thank you

I’m waiting for the driver

I see the device in device manager with the name “GENERIC BROADBAND” DEVICE

Here is the link at the image screenshot!!!

As you can see near “UBICAZIONE” (POSITION) a bounch of zeroes…that s because i think the firmware is corrupted!

Thank you for the support!

Tried both drivers you sent me:

Nothing changed
See image: still yellow warning triangle in device manager: QUECTEL WWAN recognized as GENERIC BROADBAND DEVICE with standard Microsoft Drivers installed

There is NO SIM module inserted into the slot!

Should i insert a SIM?

Thank you!

Is there any AT serial port there?
Could you use some AT command to check the status of the module?

PROBLEM SOLVED: As suggested on Lenovo forum i formatted the machine and Quectel module is back to life!

Thank you anyway for your support!