Quectel EG915 CPIN? Error 2G SIM Cards

Hi,
When I insert a 2G SIM card into the EG915 module, after a certain period of time, I receive an “ERROR” response to the CPIN? query. Initially, it works fine, but this issue arises over time. I have observed the same situation with multiple 2G SIM cards, whereas this problem does not occur with 4G SIM cards. What could be the reason for this?

Thanks.

hi,
What is the error code? You can grab a sim card identification log analysis.thanks.

Hi AnnaLiu,

→ AT
← OK

→ AT+GMR
← EG915UEUABR02A05M08
← OK

→ AT+CPIN?
← +CME ERROR: 10

→ AT+CFUN=0
← OK

→ AT+CFUN=1
← OK

→ AT+CPIN?
← +CME ERROR: 10
← +CPIN: NOT READY

Error code: Sim Card Not Inserted

The SIM card was initially functioning correctly, as were other 2G SIM cards. However, they started to develop issues over time, while the 4G SIM cards remained unaffected. Therefore, I’m not entirely confident that the problem is hardware-related. Is there a possibility that the issue could be related to the network operator? The 2G SIM cards work initially but eventually stop working. I’m having difficulty understanding this situation.

hi,
From the at command provided, is this error always reported? Is there any normal identification of 2g sim cards? It’s really hard to tell why.

I’m having the same issue. I have 3x boards with EG915N-EU modules and they all report:

AT+CPIN?
+CME ERROR: 14
AT+CPIN?
+CME ERROR: 14
+CPIN: NOT INSERTED

They worked initially but now they do not work at all
I do not think it is network related. I think it is either firmware or the circuitry inside the EG915.

What is the current version here? Is there any card replacement test?