Quectel ec25 mini pcie sim detection problem

Hello every one, We use Quectel EC25 Mini PCIE, there are many devices at field. Some devices internet connection is lost. Even if device turn off and turn on, GSM module does not recognize simd
AT+CPIN gives error or gives out put sim not ready. On order to recognize sim again, we need to take sim off and push it in again.
When we check logs, its connected to GSM module, 1 minute later, GSM Module is not able to recognize SIM.

Thank you…

Hi,
the SIM interface is often underestimated. - Please check whether your design follows the capacitance and resistance (pull-up of data line) recommendations of Quectel.
Check the parasitic capacitance of your ESD protection. TVS diodes are mostly ok, but using e.g. varistors may influence the communication between module and SIM.
Last but not least shoot some oscilloscope measurements of the SIM lines (CLK, DATA, RST).

Just my 50ct… :wink:

Cheers,
Lars

Hi,
Actually we use mini PCIE, and there are many devices with same design.
Many devices working on field. Some of our customer said that device is not sending signal to system.
It means does not connected to internet. Than we get devices. And Module does not recognize Sim Card.
When we take it out and put it back in it connects to internet.

It looks it is not related to module because even if we stop its voltage, and plug it again, it is not recognize Sim Card too.
So if there is problem about design there should be more devices with that situation. What you think?

Hi,
I fully understand your position. - But not every MiniPCIe modem has the same hardware characteristics when it comes to the SIM interface. Of course it could also be a firmware issue - what’s the version of your module?

The way you describe the problem I would really recommend you do an oscilloscope trace of the SIM communication first. Please also inspect your SIM holder, is there any bad contact in the holder or some bad soldering?

Hi again, we found the reason of problem, that turning off and turning on device again and again makes voltage fluctuation that problem, by the time, modem stop recognizing the modem. Any suggestions?

This cannot be about design. Because there are many device has same design. Also, devices works about 2 month, later they stop recognizing sim. Than gives +CME ERROR: 13 or +CME ERROR: 10.

@SmartEq_Bilisim

I’m getting exact same issue as you, have you found any clues? I posted in Quectel EC25 Mini PCIe USIM detection problem (USIM_VDD=0V)

I can also rule out its sim holder for following reasons:

  • I have around 100 terminals of 2 different models both with EC25, but different kind of SIM tray, both experience this issue
  • I also seen many times a commandline remote reboot fixed this issue, it can’t be loose connection

Sim circuit is same as reference design. I can’t flash firmware nor have a scope on hand.

Yes I write about it in thread that you said.

We have more than thousand device on field. All devices have same hardware. But this happens to some of devices that voltage fluctuates.

As you see, Quectel does not care about this problem.

I do not know why…