QuecOpen PSM-aware application WAKEUP behavior on BG96


I am trying to develop a PSM-aware QuecOpen application on BG96.
Now I can successfully enter PSM mode, but …

The device seems to restart after wake up from PSM mode, it start from quectel_task_entry() again.
Does it is normal behavior?

This is a normal phenomenon. You can understand PSM as shutting power down. The advantage it brings is to shorten a very large part of the network injection time when starting up.

any more confusion about this ,pls contact with us

Is it expected for the settings to be reset after exiting from PSM?

When the BG77 module wake up from PSM, I notice that all settings are reset to default.
Is that expected behavior?

No, normally , BG77 module will remember the last status , when it wakeup from PSM .

Do I have to save the settings with AT&W to user-defined profile so that they are does not return to the default after PSM?

For example, if i set echo mode to OFF before PSM, I notice that echo is ON after PSM.

The same behavior is with other settings such as: CEREG, CMEE, etc.
All setting are returned to default after PSM.


@Radovan Have you managed to solve the issue?

Best regards,


@rbence I didn’t solve the issue.
More precisely, I’m not sure if I have a problem or if it’s the expected behavior of the modem.

Is the expected that BG77 modem reset settings to default after exiting the PSM?

How can i be sure that my PSM is working properly?

What is the URC of BG77 modem when exiting from PSM?

Best regards,

Hi Radovan,

Actually I’m not a Quectel employee, I’m just also having issues with using PSM mode and GNSS together. :slight_smile:

When the modem enters PSM mode it will send “PSM POWER DOWN” instead of the “NORMAL POWER DOWN” message.

When it wakes up it sends “RDY” then “APP RDY” URCs either it woke up from PSM or power off mode.

In my experience, the BG77 settings are reset to the default value when it wakes up from PSM. (Except for the non volatile settigns). For example you always need to disable Echo mode after exiting from PSM.

However the modem stays connected to the network most of the time, so if you connect to the network, go into PSM, then wake up from PSM and query the network connection status (“AT+COPS?”) it will probably say that is connected.

Best regards,