"QmiWwanInit message timeout" when run ./quectel-CM in Ubuntu kernel v.5.4.0


When I ran sudo ./quectel-CM, I got those error messages “QmiWwanInit message timeout” frequently. That means sometimes quectel-CM can run successfully, but sometimes can not;

  1. Running on Supermicro
    Product Name: X12SDV-8C-SP6F
    Version: 1.02
  2. Quectel module: RM510 and RG530
  3. Connected to supermicro using a USB cable
  4. OS: Ubuntu Server 20.04 LTS
  5. Kernel version: 5.4.0-164-generic
  6. Driver installed: Quectel_Linux_Android_QMI_WWAN_Driver_V1.2.2
  7. QC Connect version: Quectel_QConnectManager_Linux_V1.6.5

I have tried reinstalling “Quectel_Linux_Android_QMI_WWAN_Driver_V1.2.2”, and then sudo modprobe qmi_wwan_q, but no use.

If anyone has suggestions is very appreciated!

Are you sure you have disabled the ModemManager?

Normally on the Ubuntu, there exits ModemManager that will also use the QMI.
And then the quectel-CM won’t work.
To disable it:

sudo systemctl stop ModemManager
sudo systemctl disable ModemManager