QFlash: when trying to load the files it shows "Fail,Get_Platform Fail"

I am trying to flash the BC660K module using the QFlash.

When I flash using the stock firmware that comes with the SDK, then QFlash flashes successfully.

However, when I try to flash using my customer build, I get the error on QFlash: “Fail, Get_Platform Fail”.

This error shows the moment I click on “Load FW FIles → Select the build files → Open”, the message shows up.

Any idea what is missing?

The current flash failed firmware is not provided by us?Your customer’s files?

Yes, the error is seen in any build I made.

The only that works are the stock-firmware located within the SDK’s folder.

I do not know if I am doing something wrong about the build or what.

But, if I use the flashtoolcli.exe, I am able to flash all the cases, but, the built from the examples or my custom file does not run. I have enabled for instance the EXAMPLE_MQTT, and it builds, I can flash it via flashtoolcli.exe, but when running it, I see nothing on serial.

Well, the issue was partially solved once I changed the ARM toolchain.

I was using the latest one 11.2-2022.02.

Then, I downgraded to the previous one 10.3-2021.10 and then I can flash the EXAMPLE_MQTT and run it successfully if using the cmdline tool.

However, QFlash still presents the same issue. I will mark this issue as solved, since now I can flash and run the binaries, although it is not possible if using QFlash, but that is not critical since cmdline works.