Q navagatior showing wrong result after registers the LTE network

Hi i am able to register the jio or private network but in tool network registration status showing not registered but by using at command i am able to see the network as registered.

please refer attached picture and at command result

[2024-05-07 16:53:13:181_S:] ATI
[2024-05-07 16:53:13:256_R:] ATI
[2024-05-07 16:53:13:256_R:] Quectel
[2024-05-07 16:53:13:256_R:] AG521REU
[2024-05-07 16:53:13:256_R:] Revision: AG521REUAAR01A01M4G_OCPU
[2024-05-07 16:54:49:185_R:] AT+CGMR
[2024-05-07 16:54:49:185_R:] AG521REUAAR01A01M4G_OCPU

[2024-05-07 16:54:49:185_R:] OK

/* Use AT+COPS? to query current Network Operator */
[2024-05-07 16:42:47:320_S:] AT+COPS?
[2024-05-07 16:42:47:409_R:] AT+COPS?
[2024-05-07 16:42:47:409_R:] +COPS: 0,0,“Open5GS”,7

[2024-05-07 16:42:47:409_R:] OK
[2024-05-07 16:44:05:887_S:] AT+CREG?
[2024-05-07 16:44:05:967_R:] AT+CREG?
[2024-05-07 16:44:05:967_R:] +CREG: 1,0

[2024-05-07 16:44:05:967_R:] OK
[2024-05-07 16:44:21:452_S:] AT+CGATT=1
[2024-05-07 16:44:21:532_R:] AT+CGATT=1
[2024-05-07 16:44:21:532_R:] OK
[2024-05-07 16:44:43:012_S:] AT+CGPADDR
[2024-05-07 16:44:43:101_R:] AT+CGPADDR
[2024-05-07 16:44:43:101_R:] +CGPADDR: 1,“”
[2024-05-07 16:44:43:101_R:] +CGPADDR: 2,“”
[2024-05-07 16:44:43:101_R:] +CGPADDR: 3,“”
[2024-05-07 16:44:43:101_R:] +CGPADDR: 38,“”
[2024-05-07 16:44:43:101_R:] +CGPADDR: 39,“”

meanwhile ping test command is not working

[2024-05-07 16:52:07:035_S:] AT+QPING=?
[2024-05-07 16:52:07:114_R:] AT+QPING=?
[2024-05-07 16:52:07:114_R:] ERROR
[2024-05-07 16:52:10:844_S:] AT+QPING?
[2024-05-07 16:52:10:954_R:] AT+QPING?
[2024-05-07 16:52:10:954_R:] ERROR

please help me to resolve the issue

I am sorry that the QNavigator do not update any more.
The QNavigator only support Quectel standard 4G modem. It even do not support the Quectel 5G modem.

hi @Bean.Wang-Q my module is support LTE i am a connecting lte network only

[2024-05-07 17:14:13:213_S:] AT+qeng=“seRVINGCELL”
[2024-05-07 17:14:13:323_R:] AT+qeng=“seRVINGCELL”
[2024-05-07 17:14:13:323_R:] +QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,1,01,19B01,1,3150,7,3,3,1,-112,-6,-88,16,255,-32768,17

[2024-05-07 17:13:36:018_S:] AT+qnwinfo
[2024-05-07 17:13:36:097_R:] AT+qnwinfo
[2024-05-07 17:13:36:097_R:] +QNWINFO: "FDD ",“101”,“LTE BAND 7”,3150

please let me know any software latest upgrade i need to do

The QNavigator will not have any new release any more.

You can check the


Any new software release for my quectel module .

please find below output

[2024-05-07 17:34:34:772_S:] AT+CREG?
[2024-05-07 17:34:34:866_R:] AT+CREG?
[2024-05-07 17:34:34:866_R:] +CREG: 1,0

[2024-05-07 17:34:34:866_R:] OK
[2024-05-07 17:34:50:123_S:] AT+CGREG?
[2024-05-07 17:34:50:218_R:] AT+CGREG?
[2024-05-07 17:34:50:218_R:] +CGREG: 0,1

[2024-05-07 17:34:50:218_R:] OK
[2024-05-07 17:34:54:353_S:] AT+CGREG?
[2024-05-07 17:34:54:448_R:] AT+CGREG?
[2024-05-07 17:34:54:448_R:] +CGREG: 0,1

[2024-05-07 17:34:54:448_R:] OK
[2024-05-07 17:35:10:973_S:] AT+CEREG?
[2024-05-07 17:35:11:085_R:] AT+CEREG?
[2024-05-07 17:35:11:085_R:] +CEREG: 0,1

[2024-05-07 17:35:11:085_R:] OK
[2024-05-07 17:35:21:420_S:] AT+C5GREG?
[2024-05-07 17:35:21:500_R:] AT+C5GREG?
[2024-05-07 17:35:21:500_R:] ERROR

That is the abnormal.

sorry i am new for quectel AT command. abnormal means network is not stable or some other issue.

what is the excepted result i need to get AT+CREG?

is 3GPP standard AT command.

thankyou @Bean.Wang-Q i have one doubt i need to set ipv4 only for my commercial network is it possible. I tried below command but getting error

[2024-05-07 17:58:12:160_R:] OK
[2024-05-07 17:59:21:462_S:] AT+Cgdcont=1,“IPv4”,“internet”,“”,0,0,0,0
[2024-05-07 17:59:21:551_R:] AT+Cgdcont=1,“IPv4”,“internet”,“”,0,0,0,0
[2024-05-07 17:59:21:551_R:] ERROR

First, the AG521REUAAR01A01M4G_OCPU is not a standard modem. It is open firmware for automative.
Some command might not support.
Secondly, you should try

AT+CGDCONT do not support to set username and password and auth type.

HI @Bean.Wang-Q i tried with jio network getting error

[2024-05-08 10:56:18:522_S:] AT+CGCONT?
[2024-05-08 10:56:18:601_R:] AT+CGCONT?
[2024-05-08 10:56:18:601_R:] ERROR
[2024-05-08 10:56:30:203_S:] AT+CGCONT?
[2024-05-08 10:56:30:297_R:] AT+CGCONT?
[2024-05-08 10:56:30:297_R:] ERROR
[2024-05-08 10:56:48:387_S:] AT+CGDCONT=1,“IPV6”,“jionet”
[2024-05-08 10:56:48:483_R:] AT+CGDCONT=1,“IPV6”,“jionet”
[2024-05-08 10:56:48:483_R:] ERROR
[2024-05-08 10:56:54:405_S:] AT+CGDCONT=1,“IPV4”,“jionet”
[2024-05-08 10:56:54:496_R:] AT+CGDCONT=1,“IPV4”,“jionet”
[2024-05-08 10:56:54:496_R:] ERROR

Seems that the AT command is not supported.
Please check wether

You can try AT+QICSGP to set APN, if it also not supported, I am afraid it is opensolution you have to set the APN inside the modem and set the APN with Quectel API.
Please check

HI @Bean.Wang-Q i am getting error for two commands

[2024-05-08 11:05:34:162_S:] AT+CGCONT=?
[2024-05-08 11:05:34:257_R:] AT+CGCONT=?
[2024-05-08 11:05:34:257_R:] ERROR
[2024-05-08 11:05:49:501_S:] AT+QICSGP=?
[2024-05-08 11:05:49:612_R:] AT+QICSGP=?
[2024-05-08 11:05:49:612_R:] ERROR
[2024-05-08 11:05:52:093_S:] AT+QICSGP=1
[2024-05-08 11:05:52:191_R:] AT+QICSGP=1
[2024-05-08 11:05:52:191_R:] ERROR

i need to set apn in qnavigator tool right in setting-apn

or any other way to set apn

it is not a standard 5G modem. It is Automative module. So some common AT command is not supported.

thankyou @Bean.Wang-Q i am testing LTE(4g) only as per data sheet this modem supports LTE

i added apn in tool but still no luck.

Please try