PuTTY Error in RM500Q-GL Firmware

DEVICE: Quectel RM500Q-GL
EMAIL: etri76442@etri.re.kr
*I want to connect the RM500Q-GL to Windows 10(UE) and perform a ping test to the USRP(gNB).

  1. When I connect the RM500Q-GL to my Windows 10 computer, I observe the appearance of AT Port (COM17), DM Port (COM15), and NMEA Port (COM18) as shown in the first picture.

  2. Subsequently, following the process depicted in the second image, I utilized QFlash_V5.5 to update the firmware of the DM Port. The version I used was RM500QGLABR11A05M4G_01.001.01.001.

  3. After this step, I verified the combination into Quectel QDLoader 9008 (COM19), as shown in the third image.

  4. Once this sequence was completed, I tried to establish a connection using PuTTY, as indicated in the fourth image.

  5. I tried to send AT command from PuTTY. However, I encountered the error displayed in the fifth image. This error persists regardless of the keyboard inputs I provide.

Could you please provide guidance on how to resolve this error? Thank you.


  2. QFlash

  3. QDLoader

  4. PuTTY


Are you trying to send AT Commands?
If that is the case then, download QCom 1.6 and connect it using, the AT Port (Com 17 in your case.)

Thank you for your answer.

I downloaded QCOM_V1.6 and sent ATCOMMAND, but when I sent AT+CGACT=1,1 CME ERROR: 30 appears. How can I fix this error?
I want to try ping test between USRP(gNB) and 5G MODEM.

How do I check if an additional SIM card contains the correct information? I think there might have been a problem here.

Error 30 means “No Network Service” check that the APN is correct. On the “Quectel AT Commands RM520 V1.2 Guide” see bottom of page 196. Where the explanation on “AT+CGACT” starts.