Program APP firmware using QMulti_DL_CMD

We’ve developed one of our products based on Quectel MC60, and we are developing manufacturing tools. We are working on a QA app that programs and tests our PCB sheet.
We want to program our PCB sheet (including 24 MC60) with our app firmware(writen in OpenCPU standalone mode) in one step. I can do it using “Quectel_Customer_FW_Download_Tool_V5.2_EN”, but it only supports eight modules to be concurrently programmed, and it doesn’t have any command-line interface. Having a command-line interface would help, as one can call the app multiple time.
I couldn’t figure out how to do it using “QMulti_DL_CMD_V2.3_EN”.
How to use “QMulti_DL_CMD” to program APP Firmware (not the entire module firmware) on MC60?
Does the “Quectel_Customer_FW_Download_Tool” have a command-line interface?
Any help in this regard is appreciated.

Dear dezdeepblue

Could you please provide your test software? And how many devices do you need to test at a time?

As I said, the PCB sheet/panel includes 24 MC60s.
Our test software is customized for our application. It sends multiple commands to check the functionality of the product. Having the proper responses from firmware will show that functionality is working fine.

Hi dezdeepblue,
Please send me your firmware, I will check it with the QMulti_DL_CMD, Thanks!

Thank you,
But the problem has nothing to do with my firmware. If you could program multiple MC60s with any provided examples, please tell me how you do it.
It would be great if you could send me the programming config for QMulti_DL_CMD for MC60.

This tool can program multiple MC60s. eg. cmd parameters is: 1 2 3 4 460800 F:\14_Firmware\MTK\MC60ECBR01A02\QUECTEL03D_M2M_11C_BB.cfg
1: module 1 com port
2: module 2 com port
3: module 3 com port
4: module 4 com port
460800: baudrate
F:\14_Firmware\MTK\MC60ECBR01A02\QUECTEL03D_M2M_11C_BB.cfg: firmware path

Thank you,
I can program the firmware flash file “MC60CAR01A13” for MC60 using the tool, but I have problem using it for programming application firmware.
let’s assume we want to program “example_gpio” firmware on multiple MC60s.
when I build the app, and then generate .bin file, the release folder in SDK directory (“OpenCPU_SDK\Release”) would be like this:


When I tried to program, it returns this:
...\QMulti_DL_CMD_V2.3>QMulti_DL_CMD_V2.3.exe 6 115200 C:\Users\dezde\Documents\Work\Eclipse_WS\OpenCPU_SDK\Release\app_image_bin.cfg
[1]Load app...
[1]Error, Bin file does not have module name and flash name!
Fail, Load firmware files failed

Please send me the config file if you could program any example firmware using the tool
Thank you

The problem is solved in the last version of the app.