Problems sending TCP data using BG95

Hi Qualcom

I am trying to send a simple API call using the BG95 modem. Based on the AT commands recomended in the TCP application.

AT+QICSGP=1,1,“websp”,"","",1 (returns OK)
AT+QIACT=1 (returns OK)
AT+QIOPEN=1,0,“TCP”,“”,80,0,1 (returns +QIOPEN: 0,0)
AT+QISEND=0 (returns >)

POST /Upload/new_unit HTTP/1.1\r\nHost:\r\nContent-Type: application/json\r\nContent-Type: application/json\r\nContent-Length: 68\r\nConnection: close\r\n\r\n
“SerialNo”: “864475046505037”,\r\n
“StatusText”: “BG95 test 44”\r\n
}\r\n\r\n\x1A (returns SEND OK)

But the data is not updated on the server. I have verified that it works well using postman with the exact same HTTP request. Am I missing something or why doesnt it work?

I have tried both buffer access mode and direct push mode, same result

when sending AT+QISEND=0,0 afterwards I get back this +QISEND: 248,248,0 so seems like data should have been transmitted…


as you said , with the URC: +QISEND: 248,248,0

that mean that , the data has been send to server

since it is http session , pls check SNI configuration ,like below

if it does not work still , pls rech to, we will send the log tools to you for more analysis

Hi Stephen

Could you please explain in more details what it is I should check with SNI configuration?

As far as I can see this relates to SSL connections, I am just trying to send a HTTP request to a website and readback the reply.

I have tried sending AT+QSSLCFG=“sni”,1,1 before opning the socket (AT-OPEN) it replies OK. But i still get not data back when sending HTTP request

Please send log tools