Problem with Quectel BC660K LwM2M registration

We have an issue with LwM2M in Quectel BC660K-GL
Using the firmware BC660KGLAAR01A05_01.200.01.200

When connecting to a leshan Lwm2m server with bootstrap we see the following:

  • if the bootstrap server sends 1 instance of the security object (/0/0) and 1 instance of the server object (/1/0) the bootstrap is completed and the device registers to the LwM2M server successfully.

  • However, if we enable this option in the last step of the configuration (Adding bootstrap server info) which writes an additional security object (/0/1) to the device.

The LwM2M registration doesn’t work anymore, we can still get the lwm2m server info but for some reason it is showing twice and the registration is failing.

Please provide your complete log

Hi @herbert.pan-Q
Could you please send the EPAT tool to capture the logs.
It would also be nice if you can share the latest available firmware version for this modem.
Thanks for your support.

I have sent them to your email,pls check

Thanks for sharing. Unfortenately, the download link for EPAT tool setup (in the pdf file) doesn’t work. Could you share another link to downolad it?

I have resent it to your email,pls check

Thanks for sharing the tool.
The logs are attached, for the failure case (With bootstrap server info), and for the success case (Without Adding bootstrap server info). (838.2 KB) (659.8 KB)

If BC660K has entered the deepsleep state, you need to execute the AT+QLWRECOVER wake up stack after waking up

Hi @herbert.pan-Q

I’ve disabled deep sleep mode using (AT+QSCLK=0) before running both tests. The current issue happens directly after bootstrapping (at registeration), and the device doesn’t enter sleep mode during this process.

We are getting (+QLWREG:0) when we don’t add the bootstrap server configration, but when we add it the registeration fails with (+QLWREG:1)

log indicates that both connections are made in BS mode

Yes we are testing 2 bootstrapping configurations, as shown in the following picture:

the client “quectel1” can bootstrap and register successfully.
the client “quectel2” can bootstrap but fails in registeration (Actually we can see from wireshark that it doesn’t send the registeration request after bootstrap) .The only difference with this client is that the bootsrap server info is added to the bootstrap config.

[2023-11-18_11:02:10:877]+QLWURC: “bootstrapping”
[2023-11-18_11:02:15:939]+QLWURC: “bs_server_retry_max_times”,1
[2023-11-18_11:02:25:962]+QLWREG: 1
[2023-11-18_11:02:53:643]+QLWURC: “bootstrapping”
[2023-11-18_11:02:58:717]+QLWURC: “bs_server_retry_max_times”,1
[2023-11-18_11:03:08:736]+QLWREG: 1

I tried both Endpointnames to initiate bs requests, but the results failed, as maybe some limitation

Can you try with
You can check the status at

Can you provide the Log for the validation test again?

I tested again with the updated Endpoint (637.5 KB) (718.0 KB)

Hi @herbert.pan-Q
Is there any update regarding this issue?