Problem locking EG25-G to LTE

I have an EG25-G with following version and firmware:


Whenever I enter the command:
I get this error:

I have read the relevant section in the QCFG manual and I do not see anything helpful.

I am able to lock to GSM, WCDMA and UMTS without problem.

I think there may be two reasons for this situation. The first one may be that there is a problem with the format of the input instruction, but it can lock other standards to explain the format of the instruction. The second reason is that the GSM, WCDMA frequency band or cell is locked, which makes it impossible to lock other systems. This check is rather tedious, so I suggest upgrading the firmware version again, so that the previous Settings will be restored, and then try to lock the LTE mode.
Best Regards

I tried with several different firmware versions with the same result each time. Then I discovered using mmcli on linux that the module did not have any LTE bands enabled (by default!). Once I enabled those I was able to lock to LTE.

For anyone interested the appropriate command on linux is mmcli --set-current-bands=“[list bands here]”.

I think there is a way to do this with AT commands but didn’t figure that out.