powerGPS not working

We have acquired recently a L86EBV-KIT, and we have installed powerGPS v2.3.5 software, by means of the USB drive.
We have installed it in 2 PCs (windows 10) but it doesn’t work. Same error in both PCs -> “24.7728839 is not a valid floating point value”.

From a link found in this forum, we have downloaded powerGPS v3, and installed it in both PCs. First error indicates: “Saving configuration to Registry happens error”.

Any clue to solve this problem??
Thanks and best regards,

Dear Sir

It can be solved by right-clicking the mouse and selecting “Run as administrator (A)” to open POWERGPS.

Best Regards

Thank you.
Running as administrator solves the error of “Saving configuration to Registry happens error”.
However, in this moment, and in both cases (v2.3.5 and v3.0.0), when we launch “PowerGPS.exe” the error window shown is the same: “24.7728839 is not a valid floating point value”.
What could be wrong?

Thank you and best regards.

Dear Sir

Please provide the log and screenshots of the test.

Best Regards

Dear Stone.Chen-Q:
Just double clicking “powerGPS” executable icon, the following window appears:
The same behavior with version v2.3.5 and v3.0.0.
The same behavior with or without connecting development kit.
Thanks for your effort.

Dear Sir

I have not encountered this phenomenon.
1.Try to decompress the software again under another hardware path.
2.Can POWERGPS be turned on normally? If you can, try to select the menu “Setting"→"Options"→"Reference Location” to modify it.As shown below:

Best Regards

Dear Stone.Chen-Q:
We have tried a laptop with Windows 7 and it works perfect.
On the other side, we have tried another laptop with Windows 10, and it appears the same error as before.

Maybe any problem with Windows 10?

For us it is ok. We will just check the development kit with the laptop with Windows7.
Thank you and best regards

Dear Sir

Please refer to the operation of the attached document to fix this problem.

Best Regards
Operation_Instuction_for_PowerGPS.pdf (825.7 KB)

Dear Stone.CHen-Q:
I have modified my PC with windows10 as indicated in the document, and now it works fine.
Thank you very much.
Best regards,

You can follow these steps to troubleshoot your GPS issue

  1. Ensure that the device is charged properly or has fresh batteries if it’s battery-operated. Sometimes, a lack of power can cause the device to malfunction.

  2. Try resetting the device by turning it off and then back on again. For some devices, there might be a reset button or a specific sequence of buttons to press for a reset.

  3. Check if there are any available updates for the device’s firmware or software. Outdated software can sometimes cause issues.

  4. Make sure there isn’t any interference from other electronic devices nearby that might be disrupting the signal.

  5. If none of these steps work, it might be a hardware issue. Contact the manufacturer’s customer support for guidance or to inquire about repairs or replacements.

If it’s a specific error message or issue you’re encountering, providing more details could help in diagnosing the problem more accurately.

1 Like