Operator selection not working on EP06-A

Revision: EP06ALAR02A08M4G

My SIM card can register on 3 operators, I am trying to lock it to one operator or set the preference for operators

Every time I run AT+COPS=?, I can’t get a response / AT becomes unresponsive. Is this a firmware issue? Can I get the newer firmware for EP06-A?

The network scan command AT+COPS=? can take a minute or more to complete. The modem will be unresponsive until it gives the “OK” response to show that the command has completed.

You can lock the modem to a single operator using the +COPS command, providing the MCC and MNC for that operator.

That can be either a hard lock or a soft lock, where the soft lock allows the modem to negotiate a different operator if the chosen one isn’t available.

For 4G/LTE, MCC= 123 and MNC = 456:

Hard lock: AT+COPS=1,2,"123456",7
Soft lock: AT+COPS=4,2,"123456",7

If locking to 3G/WCDMA/UMTS rather than 4G/LTE, replace the trailing 7 with 2.

If you want to limit the operators to a set and exclude some which are otherwise available at your location, you should be able to add the unwanted ones to the SIM’s forbidden PLMNs list. Details on request.

Thanks. For long running AT commands, how can I prevent socat from exiting?

AT+QFPLMNCFG="Add","310410" would exclude AT&T (MCC 310, MNC 410)?

If the command is supported by your firmware, I expect it will do what you want.

The alternative is to use the +CRSM command. If you want to pursue that approach, please advise the result from the AT command:


@snowgum I am also having issues with ‘AT+COPS=?’ failing after successful registration/connection/activation with a returned ‘CME ERROR: 3’ even though other network cmds like ‘AT+COPS?’, ‘AT+QNWINFO’, ‘AT+CREG?’, ‘AT+CEREG?’, ‘AT+CGREG?’, ‘AT+QENG=“servingcell”’, ‘AT+CGATT?’, etc. all return responses that show a successful network connection and activated PDP session. I’ve tried to use qmicli -d <path to device> --nas-network-scan and that eventually fails with an abort message.

Any ideas?

In an unlikely coincidence, my RM500Q-AE dropped its connection unexpectedly yesterday while I was browsing.

On checking if the SIM was readable, I was then getting “+CME ERROR: 3” from the AT+CIMI command. This error code means “operation not allowed”.

Not even a modem power cycle fixed this problem. Nor did removing and re-inserting the SIM while the modem was powered down.

A swapped to a different SIM, and that SIM worked.

I tried the non-working SIM in a different modem (EM12-G), and it worked there.

Then I returned that SIM to the RM500Q-AE. It then worked there and has been working since.

I don’t have an explanation.