Opencpu downloading on M26

I have a problem with writing OpenCPU SDK on M26.

the blow video is the steps that I have done. please tell me which step is wrong! or what should I do. I’ve tried too many things. but still, it didn’t solve!

Video of the downloading the code (2).zip (2.5 MB)

the content of the video:

1-test AT commands,connection + get version of the core SDK ===> Passed
2-Compile the SDK of the default program that should print “<-- RIL is ready -->\r\n” in the first. and echo the content of UART and answer to AT commands. ===> passed
3-try to program the module with QFlash_V5.8. (for start the downloading Pwrkey pressed)===>passed
4-after resetting the module, the desired output doesn’t appear. and the module is useless. ==> FAIL

I test with 6 GSM modules, ruined them! 3 of them are M26FA and 3 of them are M26FB!

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
the source of my OpenCPU SDK :
https://quectel123-my.sharepoint.cn/:u:/g/personal/hf-domfae_dom_quectel_com_cn/EdwYgU_6nh1Ll5y8RuZxHXgB4i1x3sd0ycrC9AAO0OxTiw?e=gmJQVz
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
the source of my Qflash:
https://quectel123-my.sharepoint.cn/:u:/g/personal/ae-fae_dom_quectel_com_cn/ERrTqT634X9EhPLFw2mGVCUBrPwQMrRYMlbbOVItc7_6Gw?e=Yxxail
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
the schematic of my board:
schematic.pdf (195.6 KB)

@WizIO @herbert.pan-Q @Grey.Tu-Q
Could you please help me?

The video show - all is ok ?!?
Ask from Quectel Support right FW for the module - I haven’t worked with M26 … only with M66

make/compile simple example ( if Eclipse is used - click and make target - this will add Mediatek header )
open application BIN with Notepad, HEX edior (just for test) … must begin with Mediatek header: MMM@ FILE_INFO…
now bin is ok
Load BIN(config) in QFlash ( every times )
PowerOFF module - Upload - PowerON … NO ERROS → OK
Run terminal @ uart and baudrate from example

NOTE: software, there is no way to damage the module … just re-flash FW

here is simple example, uart(115200) result is: BEGIN … Ril Ready

if BIN is uploaded - AT commands not work - “clear” app or disable to restore AT commands

thanks, sir,
do you know anyone who worked with M26?

dear hossein_gholami

See the help file in “Qflash” to see if the “M26” module is supported.

If yes, please click the start button after quick service module, thank you.

I have 3 versions of Qflash:

1-QFlash_V3.3 ----> does not have M26.

2-QFlash_V4.0 —> gives error : FAIL, META_ConnectWithTarget_r, [36], BootROM start command passed, but target has no response until timeout

3-QFlash_V5.8
it does not give errors, but it does not download correctly! that’s what I have used in the video.
this links:
https://quectel123-my.sharepoint.cn/:u:/g/personal/ae-fae_dom_quectel_com_cn/ERrTqT634X9EhPLFw2mGVCUBrPwQMrRYMlbbOVItc7_6Gw?e=Yxxail

1-do you have something else to check?

.
.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=–=-=
+pluse+ I could not find any help file inside. where is the help file?



=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
and by “quick service module” do mean after compiling the OpenCpu SDK?
-=-=-=-=-=-=-=-=-=-=–=-=-=-=-=-=-=-=-=-=–=-=-=-=-=-=-=-=-=-=–=-
So many thanks for your response.

dear hossein_gholami

Check your video and find that you have downloaded the firmware successfully. The secondary development process of OPEN is also normal. The physical AT port in OPEN cannot be used as AT command. The phenomenon is normal.

As for abnormal printing, it may be caused by a discrepancy between the baud rate Settings in your code and those in your software.

dear Gery,
Since you may not have noticed the code I download in the module. I review:
1-the baud rate of the uart has confined on 115200 (00:19)
so the result should print on 115200 baud rate.

.
.
and we are watching in the correct baud rate:

2- if you checked the uart callback (00:21) you may see, on this callback, the uart port should echo the things that were received and also it send it to Ql_RIL_SendATCmd, which execute the AT command.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
after all, I’m pretty sure that something goes wrong with your M26 module.
because even “Ql_Debug_Trace(”<-- RIL is ready -->\r\n");" don’t appear on the terminal.

I asked you to please grab an M26 and check it on your own.

image

dear hossein_gholami

Please check your specific hardware connection.

for downloading the code I used MAIN UART.
and in the code, I used UART PORT 1 for monitoring.
and with that USB to TLL (which I used to download the code, which that connect to MAIN UART) I have to see the logs!

I don’t get what you said! just one TTL has been used that connected to MAIN UART(or UART1)

Dear hossein_gholami

Please take a picture of the connection of your hardware. Check whether the communication voltages match.