Olimex BC66 dev kit - Getting started

I purchased the olimex BC66 dev kit and now I do not know how to best start. I tried flashing the firmware but even the Qflash tool could not establish a connection with the board. Anything I need to do upfront? I just connected the board via USB.

Another question: What is the recommended way of programming it? I know Android IDE and hoped there is something similar. But I could not find any guide which made clear what to do.

Any help appreciated.

After the dev kit is powered on, is there log output on the main UART port?

How would I do that? Newbie here… USB cable(?) to PC and then?

step1,USB to PC
step2,connect QCOM by the port

step3,press powerkey


Tried to download the qcom tool → need an quectel account (can’t login with the forum account for this) → sign up form corrupt, does not let me create an account → support form also corrupt does not let me send the form. What else should I do? You fill out the form and uppon submitting it jumps the a previous filled field and says it is required. Any other way to download the qcom tool?

I have sent it to your email,pls check

yes received. According to the olimex dev kit pinout the start button is the lower one. Nothing happens uppon pressing it except that the “Open COM Success”.
When pressing the rst button I get the following response:

FYI: no sim card inserted yet. If I run any AT command I just see an echo in the ouput.

Yes, please insert the SIM card and try debugging again

same situation. On pushing the start button nothing happens. On pushing the reset button the above response appears. On sending the ATI or AT+CSQ command the sent command appears in the response window…This time the SIM card was inserted.

Please attach your debug log and screenshots

So first I connect to the port with these settings, which is successfull.

Next, I press the start button of the bc66 dev kit → nothing happens.
Next, I press the restart button, and I get the log below. After this log I also tested the ATI command and got just and ATI in the log, see also below.

Just for fun, I have tried debugging with the arduino IDE’s serial monitor and on pressing the reset button I got something I never had before: +CPIN ready was shown additionally to the “normal” reset response. I could never reproduce this. see here:

if we could have a live chat or something on a scheduled time, i think this would be much faster. Let me know.

Are you an individual developer or an enterprise user?

enterprise R&D software devoloper looking for new project opportunities.

friendly reminder, that I am waiting for a response.

the board worked great
Tested firmware : BC66NBR01A10

maybe need COM Port drivers

you try it again

Olimex use CH340
for Linux: GitHub - OLIMEX/ch340-dkms