NSSAI (Slicing) Config Problems with Quectel RM500Q

Hi,
we try to use slicing with the RM500Q-GL in a SA 5G setup
FW: RM500QGLABR11A03M4G

If we use SST: 0 and SD: 0 it works (it is also configured in gNodeB and Core), but if we try to change the SSD / SD config it does not work.

I see other Topics with the same error, but i did not see the a solution.

I tried to changed the PDP config, but my try result only an error:
AT+CGDCONT=2,“IP”,“oai”,“0.0.0.0”,0,0,0,0,“82.000082”,0

Thanks for tips or solutions

best regards
Jonah Mons

1 Like

I’m still looking for a solution, any help and tips is welcome :slight_smile:

i try a lot in the meantime and maybe i have figured it out :slight_smile:

To Change the slicing follow this instruction:

  1. Modem needs a running NSSAI config (this means: UE has to be connected to a running gNodeb / Core setup !)
  2. Than Modem can be set to an other configuration with AT+C5GNSSAI
    e.q:
    AT+C5GNSSAI=4,“01.ffffff”
    AT+C5GNSSAI=4,“01.000001”
    Can be checkt with AT+C5GNSSAIRDP=3
    Result:
    +C5GNSSAIRDP: 4,“01.000001”,1,“01#0” ← Target state
    +C5GNSSAIRDP: “20895”,4,“01.000001” ← current state, this have to be matched to the running environment !
  3. Modem has to be restarted, plug out and plug in, NOT WITH CFUN=1,1 !
    If you remote, look at usbreset How do you reset a USB device from the command line? - Ask Ubuntu
  4. Modem should be have now the new slicing configuration, check again with AT+C5GNSSAIRDP=3, last item in list have to be your configuration

this follow the 3gpp definition: Take care on following document: https://www.etsi.org/deliver/etsi_ts/124500_124599/124501/16.09.00_60/ts_124501v160900p.pdf → Section 4.6.2.2