Not going in sleep directly after AT+QNBIOTRAI

hi as mentionned in the title afte qnbiotrai the module is not going in sleep directly it takes a few seconds but the first time it goes in sleep directly , I dont see the message exit from psm . in bellow you fill find my logs

AT+

⸮Button Pressed
03:06:36.170 -> RTC time : 0 Days, 0 Hours, 0 Minutes, 35 Seconds
03:06:36.237 ->
Button press cnt : 1

03:06:36.403 -> Hourly Frame
03:06:36.403 -> RTC time : 0 Days, 0 Hours, 0 Minutes, 36 Seconds
03:06:36.469 ->
0000bb7465f504ab

03:06:36.502 -> sending frame

03:06:37.133 -> get ip dnsDNS 1 ? ;

03:06:37.233 -> OK

03:06:37.299 -> DNS IP ? ; QIURC: “dnsgip”,“35.180.26.233”

03:06:37.333 ->

03:06:37.366 -> ip telegraf.shayp.io ?;35.180.26.233

03:06:37.399 -> create socket connectiontimeout

03:06:37.665 ->

03:06:37.698 -> socket connection?;

03:06:37.698 -> OK

03:06:37.698 ->

03:06:37.731 -> +QIOPEN: 0,0

03:06:37.731 -> signal?timeout

03:06:37.897 ->

03:06:37.897 -> signal;

03:06:37.897 -> +CSQ: 10,0

03:06:37.930 ->

03:06:37.930 -> OK

03:06:37.930 -> quality 10

03:06:37.930 -> force trai ?timeout

03:06:38.096 ->

03:06:38.096 -> trai ?;

03:06:38.129 -> OK

03:06:38.926 -> send:

03:06:38.926 -> OK

03:06:38.959 -> close sockettimeout

03:06:39.191 ->

03:06:39.191 -> close socket?;

03:06:39.225 -> OK

03:06:39.225 ->

03:06:39.225 -> OK

03:06:39.225 ->

03:06:39.225 -> SEND OK

03:06:39.225 ->

03:06:39.225 -> CLOSE OK

03:06:39.258 -> put in sleep ?timeout

03:06:40.055 ->

03:06:40.055 -> sleep ?;

03:06:40.055 -> +QNBIOTEVENT: “ENTER PSM”

03:06:45.431 -> Button Pressed
03:06:45.431 -> RTC time : 0 Days, 0 Hours, 0 Minutes, 45 Seconds
03:06:45.487 ->
Button press cnt : 2

03:06:45.763 -> Hourly Frame
03:06:45.763 -> RTC time : 0 Days, 0 Hours, 0 Minutes, 45 Seconds
03:06:45.806 ->
0000bb7465f504ab

03:06:45.852 -> sending frame

03:06:46.461 -> get ip dnsDNS 1 ? ;

03:06:46.561 -> OK

03:06:46.609 -> DNS IP ? ; QIURC: “dnsgip”,“35.180.26.233”

03:06:46.660 ->

03:06:46.660 -> ip telegraf.shayp.io ?;35.180.26.233

03:06:46.708 -> create socket connectiontimeout

03:06:46.926 ->

03:06:46.926 -> socket connection?;

03:06:46.926 -> OK

03:06:46.960 ->

03:06:46.960 -> +QIOPEN: 0,0

03:06:46.960 -> signal?timeout

03:06:47.125 ->

03:06:47.125 -> signal;

03:06:47.125 -> +CSQ: 10,0

03:06:47.158 ->

03:06:47.158 -> OK

03:06:47.158 -> quality 10

03:06:47.158 -> force trai ?timeout

03:06:47.324 ->

03:06:47.324 -> trai ?;

03:06:47.324 -> OK

03:06:48.155 -> send:

03:06:48.155 -> OK

03:06:48.155 -> close sockettimeout

03:06:48.354 ->

03:06:48.354 -> close socket?;

03:06:48.400 ->
03:06:48.400 -> +CEREG: 2

03:06:48.400 ->

03:06:48.400 -> +QNBIOTEVENT: “EXIT PSM”

03:06:48.440 ->

03:06:48.440 -> OK

03:06:48.440 ->

03:06:48.440 -> SEND OK

03:06:48.440 ->

03:06:48.440 -> CLOSE OK

03:06:48.470 -> put in sleep ?timeout

03:06:49.184 ->

03:06:49.184 -> sleep ?;

03:06:49.225 -> +CEREG: 1

03:06:49.225 -> put in sleep ?read timeout inPSM

03:06:59.006 ->

03:06:59.006 -> sleep ?;put in sleep ?read timeout inPSM

03:07:08.829 ->

03:07:08.829 -> sleep ?;put in sleep ?read timeout inPSM

03:07:18.650 ->

03:07:18.650 -> sleep ?⸮⸮Button Pressed
03:08:06.475 -> RTC time : 0 Days, 0 Hours, 2 Minutes, 6 Seconds
03:08:06.510 ->
Button press cnt : 3

03:08:06.740 -> Hourly Frame
03:08:06.740 -> RTC time : 0 Days, 0 Hours, 2 Minutes, 6 Seconds
03:08:06.807 ->
0000bb7465f504ab

03:08:06.840 -> sending frame

03:08:07.438 -> get ip dnsDNS 1 ? ;

03:08:07.570 -> OK

03:08:07.637 -> DNS IP ? ; QIURC: “dnsgip”,“35.180.26.233”

03:08:07.670 ->

03:08:07.707 -> ip telegraf.shayp.io ?;35.180.26.233

03:08:07.736 -> create socket connectiontimeout

03:08:08.002 ->

03:08:08.002 -> socket connection?;

03:08:08.043 -> OK

03:08:08.043 ->

03:08:08.043 -> +QIOPEN: 0,0

03:08:08.043 -> signal?timeout

03:08:08.201 ->

03:08:08.201 -> signal;

03:08:08.238 -> +CSQ: 9,0

03:08:08.238 ->

03:08:08.238 -> OK

03:08:08.238 -> quality 9

03:08:08.275 -> force trai ?timeout

03:08:08.400 ->

03:08:08.443 -> trai ?;

03:08:08.443 -> OK

03:08:09.231 -> send:

03:08:09.265 -> OK

03:08:09.265 -> close sockettimeout

03:08:09.497 ->

03:08:09.497 -> close socket?;

03:08:09.538 -> OK

03:08:09.538 ->

03:08:09.538 -> OK

03:08:09.538 ->

03:08:09.538 -> SEND OK

03:08:09.538 ->

03:08:09.538 -> CLOSE OK

03:08:09.588 -> put in sleep ?read timeout inPSM

03:08:19.359 ->

03:08:19.359 -> sleep ?;put in sleep ?

1 Like

Hi Zineddine
I don’t know what parameters are set by AT + QNBIOTRAI?
ENTER PSM is just that the module modem enters PSM mode, but the module AP does not enter PSM mode.

The module enters the Sleep Mode when Sleep is enabled, no network activity and kernel “stays” in the idle task
User can not control ( only enable/disable ) Sleep Mode - kernel PSM manager control this

on a other post you told me to put the AT + QNBIOTRAI=1 before sending a message so the device will go in sleep after sending directily is that still correct?

regards

Hi Zineddine
You can have a try, execute AT + QNBIOTRAI = 1 before sending data every time.