Not getting GPS details- RM520N-GL module

My module firmware version
RM520NGLAAR01A06M46.
i am not receiving GPS location details and constantly showing CME Error : 516
This version supports GNSS or not?
If firmware update is required pls share latest firmware and QFirehose tool for linux to my mail.
manikantananda777@gmail.com
thq

Dear @iotmani
Please help to confirm if the GNSS turn on, you can query via AT+QGPS?
I also sent the GNSS application note and latest firmware via Message, please check.

showing +QGPS =1 and AT+QGPSLOC=0 is +CME 516 error.
I am using single passive antenna connected at A3 interface for mobile network and GNSS and antenna at open sky condition.
Tq

Hi i tried on a BG95 with those AT commands:
try AT+CFUN=0 to turn off cellular network, then AT+QGPSLOC=4,2, you’ll get empty NMEA sequences until GPS fix. It can take several minutes to get a fix.

If you still doesn’t get a fix, then try AT+QGPSEND, AT+CFUN=1, confirm you are registered on a network with AT+CREG?, and then try donwloading XTRA file

AT+QGPSXTRA=1 //Enable XTRA and then restart the module to activate the feature.
OK
AT+CEREG? //Check the network status.
+CEREG: 0,1
OK
AT+QGPSXTRATIME? //Check XTRA time. Inject XTRA time if it is not available.
+QGPSXTRATIME: “2020/07/20,02:34:47”
OK
AT+QGPSCFG=“xtra_info” //Check whether the existing XTRA file has expired.
+QGPSCFG: “xtra_info”,0, “2020/07/16,06:00:00” //XTRA file is expired.
OK
AT+QGPSCFG=“xtra_download”,1 //Trigger XTRA file downloading.
OK
+QGPSURC: “XTRA_DL”,0 //The XTRA file is successfully downloaded.
AT+QGPSXTRADATA? //Check the validity of the existing XTRA file.
+QGPSXTRADATA: 4320,“2020/07/20,06:00:00”
OK
AT+QGPS=1 //Start GNSS with XTRA.
OK

and repeat commands from my post’s beginning
best regards