Not able to get DNS but got Ip

Hi I am using eg25-g on linux
I tried Quectel CM application to get the 4G connection I am able to ping IP address but not able to ping not working I believe)
I Moved the script file to both folders as you suggested
here’s the log

sudo ./quectel-CM -s

[10-15_13:39:52:554] Quectel_QConnectManager_Linux_V1.6.0.12k

[10-15_13:39:52:555] Find /sys/bus/usb/devices/1-2.1 idVendor=0x2c7c idProduct=0x125, bus=0x001, dev=0x007

[10-15_13:39:52:556] Auto find qmichannel = /dev/cdc-wdm0

[10-15_13:39:52:556] Auto find usbnet_adapter = wwan0

[10-15_13:39:52:556] netcard driver = qmi_wwan_q, driver version = 22-Aug-2005

[10-15_13:39:52:556] ioctl(0x89f3, qmap_settings) failed: Operation not supported, rc=-1

[10-15_13:39:52:556] Modem works in QMI mode

[10-15_13:39:52:590] cdc_wdm_fd = 7

[10-15_13:39:53:591] QmiThreadSendQMITimeout pthread_cond_timeout_np timeout

[10-15_13:39:54:676] Get clientWDS = 17

[10-15_13:39:54:708] Get clientDMS = 1

[10-15_13:39:54:739] Get clientNAS = 3

[10-15_13:39:54:772] Get clientUIM = 2

[10-15_13:39:54:804] Get clientWDA = 1

[10-15_13:39:54:836] requestBaseBandVersion EG25GGBR07A07M2G

[10-15_13:39:54:963] requestGetSIMStatus SIMStatus: SIM_READY

[10-15_13:39:54:964] requestSetProfile[1] ///0

[10-15_13:39:55:027] requestGetProfile[1] ///0

[10-15_13:39:55:059] requestRegistrationState2 MCC: 525, MNC: 3, PS: Attached, DataCap: LTE

[10-15_13:39:55:092] requestQueryDataCall IPv4ConnectionStatus: DISCONNECTED

[10-15_13:39:55:093] ifconfig wwan0 down

[10-15_13:39:55:116] ifconfig wwan0

[10-15_13:39:55:188] requestSetupDataCall WdsConnectionIPv4Handle: 0x872a7930

[10-15_13:39:55:317] ifconfig wwan0 up

[10-15_13:39:55:340] busybox udhcpc -f -n -q -t 5 -i wwan0

udhcpc: started, v1.27.2

udhcpc: sending discover

udhcpc: sending select for

udhcpc: lease of obtained, lease time 7200

[10-15_13:39:55:545] /etc/udhcpc/default.script: Resetting default routes

SIOCDELRT: No such process

[10-15_13:39:55:555] /etc/udhcpc/default.script: Adding DNS

[10-15_13:39:55:555] /etc/udhcpc/default.script: Adding DNS

I dont know what’s this error SIOCDELRT: No such process

Can you please help me asap ?
I have been working on this modem for quite a long
Thanks in advance


About: SIOCDELRT: No such process
This problem occurs because the gateway you want to add is not in your host network segment

So what should I do now ? should I add manually or reset ?
Can you help me how to proceed from here ?

From your log you can try the following.

For example, the gateway you want to add is
route add dev eth3 then route add default gw or route add -net gw 12.12.12

I tried Adding and after that I pinged still not able to ping
what do you think the issue is ?