Need help for PH-NET sim lock and latest firmware (not beta version) for my HA5420 5G modem


Hi, I have a problem with my modem, it’s worked earlier but now it wants me to unlock the mccmnc ph-net sim lock! Don’t know what to do…the modems model HA5420 5G, and I need a clean latest firmware version to re-install and unlock the sim ph-net lock! The current firmware version is:
RG500LEUACR04A03M8G_OCPU_BL_BETA20230427_20.200.20.200

Even when I disable the mcc-mnc section; Again, my sim cards (which work fine in other devices) are locked in this modem and not working. That means it is not allowed. In the meantime, I noticed that my firmware is of beta type.

Hi @Al1

Please contact the local FAE to release the version and SDK, or your purchaser. I am unable to release the version and SDK here. If you are using an open solution, you will need the version and SDK

Thanks

سلام حالت خوبه ، راهی براش پیدا کردی ؟

Hi everyone,
I have a HA5420 modem. I accidentally selected the SIM lock option in the modem settings, and now the modem is locked. Even after a factory reset, the modem is still locked. It seems like this is a bug in the firmware version of this device.
Can anyone tell me where I can download the firmware for this modem? I couldn’t find it anywhere!
Thanks in advance for your help!

Is your problem solved with this modem?

I have the same problem as you