Multiple EC25-A modules fail. No boot?

I have more than 10 units with a failing quectel EC25-A module that are defective. I’m unable to diagnose further. It seems to have everything the module needs but isn’t working. We know that all of them have worked when testing during production but when unresponsive, some even wile just sitting on the shelve before going out in the field. Please help me diagnose further, we have had a few more units with common problems but now it’s a big batch.

This is what we know:

Power input: OK
PWR and RST key: OK
Status: Not OK, stays HIGH - should go open drain after 2.5 sec
NET_STATUS: Not OK, stays LOW - should flicker indicating searching network
VDD_EXT: OK steady 1.8V

Creates Comport on USB: HS-USB QDLoader 9008, unable to set in gsmhack mode to create the other COMports for communication so far.

Resoldered outside contacts, detached from communication lines, powered by lab bench power supply:
42 mA @ 3.8V

How to continue?

Dear P.Muis,
Please check the status of the following USB_BOOT pin.It should be low.
If this pin is ok, you can try to re flash the firmware to have a try. Thanks!

Hy Kyson,

Thanks for the help, that helped with that piece.

I have a different one with exactly the same problem, only the power use is not as stable, going from 55mA to 170 mA @3.8V and it doesn’t create a comport when plugging in. USB_BOOT is LOW. How can I reprogram this one, assuming the firmware is the problem?

*edit, I have two with this problem

Dear P.Muis,
If you want to re-flash the module firmware, please email to to get the firmware package and the flash tool. Thanks!

Hi Kyson,

I already have firmware and have used Qflash4.7 to put it on the first module, which solved the problem. Now I have multiple modules that don’t create a COMport. I don’t know how to flash a module that doesn’t create a COMport. Is there another way to flash the Quectel module?

You can try to connect module USB_BOOT pin to VDD_EXT pin, it will appear the QDloader port, then you can flash the firmware. Thanks!

Thank you. I’ve now been able to flash the Quectel. The only question that remains is how is it possible for modules to require reflashing? We’ve run the units through tests at production, afterwards in the field they don’t work or stop working after a while.Do you have any idea’s what could cause this?

Dear P.Muis,
It is hard to say what is the root reason, but just pay attention to that you should make the power supply for module is stable, power on or off the module should follow up the suggestion, and do not send AT+CFUN=0, and AT+CFUN=1 frequently. Thanks!