Modem stuck in firmware update

Hey there,
I’ve recently spoken to Yann who gave me a firmware upgrade package for my EC25-E. I’ve started the firmware upgrade about 15 minutes ago and it’s still suck updating. It’s currently at send NON-HLOS.ubi and it’s not progressing.
I’ve just decided to abort the upgrade there and as expected now the modem won’t even respond to another upgrade attempt. Great.
Any idea how to proceed from here? I’ve found some instructions to reflash the modem via fastboot but that’s still a stupid issue…
Thanks!

Edit: yeah the modem doesn’t even come back after a power cycle. I done fucked it didn’t I

1 Like

since I’ve reached the max amount of edits:

  1. The usb interfaces in /dev/ttyUSB* don’t appear anymore
  2. I don’t think I can flash the modem via fastboot since I cannot open a serial connection to the modem. That seems to be one of the non-standard features of the mini-pcie pinout, and I can’t access those pins while the modem is seated into the mini-pcie slot.

Seems like a surprisingly unrecoverable situation

1 Like

the usb serial console has luckily reappeared. Wanted to get into EDL mode but it’s just not doing it.
If I just touch VDD_EXT and USB_BOOT together while booted nothing happens at all.
rebooting my system afterwards and as such also power-cycling the modem doesn’t work either.

Are there some reset pins on the modem that I need to use?

1 Like

finally figured out how to get into EDL mode. EDL mode is in fact QDL mode on the modem.
I had to first short VDD_EXT and USB_BOOT together, and then suspending and resuming the system actually made the modem visible.

Then, finally, the god damn firehose flashing utility worked. What an endeavour.

Let’s hope it doesn’t shit itself again during the flashing process.

1 Like

Note for the previous reply: You apparently need to suspend a second time after the modem pops up in lsusb otherwise it won’t respond to the hello request by the firmware flasher


yeah so I think I need help with this one. The firmware upgrade and flash utility is somehow really bad at doing exactly that.

I’ve tried like four flashes now and each time it gets stuck mere seconds after starting a flash.

First time it got stuck at five dots, second time at two, third time at one and now it’s stuck at three dots.

1 Like

left another update running for two hours and got zero progress after the initial hang (this time it randomly made it to the ubi file again, it’s pretty random how far it gets before it dies). it’s definitely not finishing. the firmware update tool seems to have some issues

1 Like

is there a way to enter fastboot mode in EDL mode? that would allow me to bypass the flasher…

I’d like to avoid killing the internal flash or causing other means of damage though trying too many firmware flashes.

Any idea what else I could try?

The main thing keep copy of QCN to avoid losing the network …
The great thing ,you figured how to do EDL mode by your self
The funny thing is Quectel didn’t support in this post

As I know you can’t bypass the flasher

really disappointed about that. I’m a paying customer and received zero support for something that the officially supported flasher tool does wrong.

At this point it seems that all I can do is try to flash over and over again until I finally get a lucky flash and get that stupid firmware onto the modem. Had a flash that got up to fourty percent earlier today, but since then it’s been getting stuck at the very beginning again.

Edit: And yes, I have unloaded the qcserial kernel module, and yes, I have stopped ModemManager. This is not my fault.

it’s actually amazing. I’ve just spent hours installing windows just to try the fucking windows flasher and now I’m told that I need to contact support to download the mother fucking windows driver.

Fuck this place.

Hi @bananu
I am very sorry for my late arrival. Is your current problem that the upgrade is unsuccessful? What upgrade tool are you using?

yes. The upgrade doesn’t finish. It hangs at random parts during the installation. It’s completely unpredictable where it stops, but when it does, it stops indefinitely. I’ve let one upgrade running for several hours with no change.

Currently the only upgrade tool I have access to is QFirehose. I would try the windows QFlash flasher, but I’m missing the driver. I’ve already contacted support for that.

well, thanks for the driver, but I’m running into another issue. Apparently the windows drivers are unable to detect a modem in EDL mode (or that other mode that it’s currently in, that also does nothing).

So QFirehose apparently is my last resort, but that last resort doesn’t work at all

It appears that after the upgrade was interrupted, the system files may have been damaged and will not boot properly.

Windows can detect EDL mode port, you can not see it in the device manager? qflash doesn’t recognize ports either?

I can’t see it in devicemanager. It could be the device that windows sais the device descriptor request failed for. It definitely shows up on Linux fine, in the broken boot mode it was in, and EDL mode as well.

It does appear that the "WAN Miniport (something something) devices in devicemanager are the modem, but none of them are de-facto called EC25, or even mention Quectel

Qflash shows zero available com ports

(this six minute reply cooldown is really annoying.)

Okay, I’ll find an EC25 module and go into EDL mode. In addition, we can also communicate in chatbox, where there is no waiting time.

the downside to that being that nobody else will be able to see what the problem was and how to resolve it. I guess I’ll have to summarize our chat after the fact.

Update:
The latest version(s?) of QFirehose have some regressions in the code.
Flashing worked fine using version 1.2.

I have compiled all the files you might and might not need here: Quectel

Thanks for the help, lyman!

(HMU if you want the link removed - or just remove it yourself :wink: )