MC60 Reference Location problems


I’m working in a solution to use AGPS in a MC60 module using stand-alone mode, I can’t use quecfastfix or any other resourcer because my product only comunicate with my server, it’s all ready to use the epo files are on the module, I just can’t input the reference location, the only tool for this that I found is the command AT+QGREFLOC, but it’s seens to function only in all-in-one mode. There is a way to input reference location that the module can use without quecfastfix?

edit: I’ll need to update the time too, I tried the AT+CCLK but does’t work;

Best regards,

Vitor Amorim

Hello, although it is in standalone mode, AT+QGREFLOC instruction should be able to be used in the same way. If it is MC60 standard module without OCPU, we can only set reference parameters through AT+QGREFLOC AT present


I tried using qgrefloc but not seems to work, as mentioned in the chapter 2.1 of the AGPS manual I think it’s will not work in stand-alone. I’m not using OCPU.

There are any other possibility to send reference location direct to the GNSS module?

Hi,May I know your firmware version? Please use “ATI” command, I’ll see if there’s another way to set up the reference for you


You can try sending AT commands through GNSS pins instead of MC60 pins

Hi Vitor
When using standalone mode you need to use the GNSS UART pins to send data directly into the GNSS. Please take a look at Quectel_MC60_Series_GNSS_Protocol_Specification document.
Also please make sure that the HW connections for the GNSS UART are the ones in the Quectel_MC60_Hardware_Design page 61 and 62. Hope this helps.

Hello Diogo,

I’m using the GNSS UART but just for pmtk commands and sending the epo files. The connections are just like the manual said.


I can send the AT+QGREFLOC command direct trought the GNSS pins or I need to set any configurations before the AT, I tried here and did’t get any answer for the module.

Hi , maybe you could use an example


I trying some things in the EVB with a MC60, as I said before my simcard does’t communicate with anything than my server, so the functions that need internet information does’t work, AT+QGNSSEPO, AT+QGEPOAID as example, I downloaded the EPO files according to this manual, using the PMTK607 the EPO file are in the modem and it is using the correct file interval(6h), but the command AT+QGEPOF=0,255 shows that there is none EPO file in the modem, so I start to think, the AGPS function works without using the Quecfastfix or EPOTM? Even in All-in-one I can’t achieve a TTFF less than 25s.

In this case I used the EVB in all-in-one mode for testing porpouse

best regards.

According to the diagram, there is no EPO file in your module. First, you need to make sure that your EPO file is completely downloaded. It takes some time to download EPO file according to different network signals. Always use AT+QGEPOF=0,255 to query the file. If successfully downloaded, the file size should not be negative

Also, you should make sure your module has a GSM antenna and a GNSS antenna