MC60 :problem with Flashing

I’m working with mc60 module while flashing through QFLASH tool I’m getting the following problem, but before it was worked fine. the problem getting is
FAIL, META_ConnectWithTarget_r, [36], BootROM start command passed, but target has no response until timeout, can anyone give a quick reply

Dear Sir,
About the issue you met, please check the following information: should use main UART port and make sure no any other interference on this port when upgrading firmware;
2.after the port is selected, please make sure manually restart the module;
3.make sure the serial port cable is normal, and the connection is normal;
4.if all the above confirmed have no any abnormal, please try change another serial cable, another PC or another version Qflash to have a try.
Hopefully the above are useful to you. Thanks!

Dear sir,
I have followed all the steps you have written for my query. still, I am unable to flash the open-CPU MC60 2g module.
finally, I observed the abnormality what I’m getting while flashing is not matching with our quectel Qflash I’m attaching my problem with the screen shorts, so please find a solution, let me know as soon as possible.
actually, with the same MC60 module, I Flashed some examples given in SDK and they were worked fine when I was flashing “core firmware” of mc60 the problem was came

Dear Sir,
please change another version QFlash tool, you can click the following link to download the tool. Thanks!

Pay attention to that the firmware path should have no any special character, or space, you can change the path to desktop to have a try again. Thanks!

1 Like

Dear sir,
I have downloaded the QFlash tool from the link you were given, and I have tried to flash the firmware, it has done. while flashing it has waited at boot media at broom stage and finally it has showed the message FW upgrade success but I was not getting any messages from the main uart and the debug uart, so after that i was done the flashing through command line method given in our QFlash documentation. then i have seen the messages same as while I’m flashing through QFLASH 4.0, so the problem was not solved, I’m sharing the problem. so please find a solution and let me know what happend.

Is your Aux UART looped back to the GNSS UART?

Hey I also faced this issue while uploading bootloader code for mc60. I have faced this issue only when i tried to upload it to my customized board.with Evb kit it doesn’t happen generally.make sure all your connections are perfectly fit .

Hello, I have the same problem
Does anyone know what the solution is?

My problem is solved
When you buy a module as a development board, a default firmware is uploaded on it, but if you buy the module alone, you must first upload the default firmware, which is available in the files you download from the Internet under the title “Default mode of MC60”.