MC60 doesn't boot example firmware

Hello. I’m facing issue like here.
I’m using sdk 1.7. Flashing go well, but after reboot it spams Boot failed, reset… or keeps silent.
When i flashed custom example in first time, it was well, but when i reflashed it with another, it had no affect (printf in uart was the same). Does QFlash not removing current fw? What am i doing wrong?
I’m using QFlash 4.19 and every time process completes correctly.
Also I have questions what firmware is placed in \QFlash_V4.19_EN\QFlash_V4.19\Release\dl_src\MC60?
Why it has different cfg file from generated from sdk? What is ROM, VIVA, EXT_BOOTLOADER and so on?

Hi Roman
I think you are browsing the incorrect cfg file after compiling the code.
Hope so your using command line SDK for MC60
please change the preprocess for compiling the correct example from below location of the SDK.

then compile and build the code using MS-DOS prompt by make clean and make new

your updated build file will be stored in \MC60_OpenCPU_GS3_SDK_V1.7\build\gcc
browse app_image_bin.cfg file from above location in qflash and flash the program in MC60.


Thanks for your reply.

I used sdk in command line and in eclipse, same result. Compilation and flashing goes well, but device does not response to AT commands.

I used qflash 4.19.
Maybe I erased some important sectors when tried to flash this (\QFlash_V4.19\Release\dl_src\MC60\1)?

Can you please send me base firmware wich is 100% working? That is shown in qflash user guide pdf

you can download the latest firmware for MC60CA from below link

I download the latest firmware for MC60CA from you link.

Please explain to me how to use the file MC60CAR01A13_UPGRADE.bin located in the folder upgrade?