MC60 breaked after none modified custom fw flashed

I’m totally a newbie so please excuse me if asked anything dumb in first place.
I have bought a GSM EVB + MC60E-TE-A and downloaded latest openCPU SDK (MC60_OpenCPU_GS3_SDK_V1.7), make clean/new. flash it using QFlash v4.13 (while S202 & S201 on). Everything goes smooth and QFlash ended with PASS.Power off the board and turn S201 back to off but I have activity in terminal. Even no AT commands returns anything. Is there anyway that I have break the MC60? Is there any suggestion on how to get out of current situation?
By the way, the only LED which is on is POWER and nothing else. I wonder where can I find the standard firmware to flash and see if the chip is working?
Thnx in advance

if you load user application you not have AT commands - uarts is controlled by application
if you want to disable application:

static const ST_AppEnable appEnableCfg = {
compile and upload … then module will work as normal with AT commands

Thnx WizIO, just done what have you suggested, but still the same. Is there any way to reset to original firmware to see if the chip is ok?
By the way, origianl sample of SDK contains code to accept command from UART and execute/return the result.

the firmware update only kernel part from flash memory
application is other part from memory map
only appEnableCfg enable/disable user app for M66/M60 modules

Thnx WizIO for rapid response, I really appreciate that. One last question. Is there any chance that I can corrupt kernel part accidentally while playing for QFlash? Cause I have tried QFlash V4 which is in tools directory of SDK and I got “FAIL, META_ConnectWithTarget_r, [36], BootROM start command passed, but target has no response until timeout,”
And also in QFlash user guide, it was mentioned that core Firmware is possible to be flashed into MC60 but I couldn’t find it anywhere.

you can not corrupt the module - there is ROM boot loader and module always have boot mode for update
btw: M60 and M60E is different modules - if you flash with wrong firmware module cannot run but can be updated

Oh, I have MC60E. Where can I find the openCPU for MC60E?

:slight_smile: from Quectel

:sweat_smile::sweat_smile::sweat_smile: A direct URL would be very helpful mate.By the way, I have also checked your extension on platformIO, does it contains the MC60E?

not for now - need time and module…

I have got the MC60E SDK and tried again, but the situation is the same. I have noticed that as Kyson mentioned in this post MC60 problem with flashing firmware, my QFlash does not go through clear Nv sysfiles stage at all! Can it be the cause of my problem??

I don’t know … try update firmware first
Then compile app with option APP_DISABLE and upload app
And check for AT Commands

Thnx mate, just reflush with new firmware and everything back to normal!

1 Like

BTW: some firmwares have part ( firmware.cfg ) for removing user_application and not need APP_DISABLE

1 Like