M95 Problems receiving SMS

I have a setup with Arduino and Mikroe gsm2 which has a M95.
I can easily connect to my servers, and send data using post and then read the data.
I can also easily do GET and read data.

I can even send SMS, so I think we can rule out problems between the Arduino and the M95 module :slight_smile:

But receiving SMS is a completely different thing. I simply cannot get it to work.
I do:
AT+CPMS? and there are 3 messages on SM
I then do:
AT+CMGF=1
AT+CSDH=1
both respond OK
I then do:
AT+CMGR=1
And I get:

+CMGR: “REC READ”,"+45xxxxxx","","2020/12/23 10:23 10:3
I’m aware there are newlines etc so I try to keep reading until I get OK or timeout after 12 seconds (just defined 12, I know it should not take this long)

So, I get information about the message, but not the content. Why?

Thanks in advance

Some more info. If I do:
AT+CMGL=“ALL”
I get:

+CMGL: 1,“REC READ”,"+45xxxxxxxx","","2020/12/

And nothing more. even though AT+CPMS? returns:

+CPMS: “SM”,3,50,“SM”,3,50,“SM”,3,50

Which indicates to me, that not all characters are sent from M95 to the Arduino.
Though… I can get huge datasets from my POST :frowning:

Hi Jarl_Gjessing

Have you solved your problem?
I have a similar situation on BG96.
There is no way I can get my BG96 to send the +CMTI message after receiving the SMS.
No parameter configuration in the AT+CNMI command helps.

My BG96 firmware version: BG96MAR02A07M1G_01.017.01.017

Anyone have any idea?

I made upgrade to BG96MAR02A07M1G_01.018.01.018.
And still no +CMTI and +CMT messages.
How to receive SMS?

Unfortunately no.

And it would seem that someone else would now how to fix this, since I guess there is one or two that have received SMS’s with Quectels products :slight_smile:

But I’m happy that I’m not the only one that has this issue though.
I will definitely post a solution here if I get one, and boy, would I like to hear yours if you find any.

@gkania
Hi for BG96 you have to configure the port for URC indication, please refer below command


by default it is set to “usbat” i.e. USB AT PORT for main uart you have to set AT+QURCCFG=“urcport”,“uart1”

1 Like

@Jarl_Gjessing
I think you are not able to receive the complete data(message strings) from the modem to Arduino. Can you send AT commands to M95 directly through any serial terminal tool instead of the Arduino and test it.

I will try this later when I’m at the office, thanks

“Not able to receive”
If this was the case, then I would not get all the data I receive when reading post data where I receive about 1kb data, no problem

Hi @Jarl_Gjessing
Request you test with the any serial terminal tool and share the logs

Hi @rahul.mahakalkar
You were right. It was necessary to use the command
AT+QURCCFG = “urcport”, "uart1"
to switch the destination port of incoming URC messages.
But there is still something wrong with the +CMTI notification. I don’t get it when SMS comes in. I can see the incoming SMS in the modem’s memory with the AT+CMGL command. I don’t know why +CMTI doesn’t come.
But what is strange: the +CMTI message comes at the end of the ringer (regular voice call). Then it shouldn’t.
So it still doesn’t work for me. :frowning:
My firmware BG96MAR02A07M1G_01.018.01.018

It works.
My memory of incoming messages was full. :slight_smile:
Although it is a pity that in such a situation it does not send a +CMTI notification or some other.
Thanks for the help.

Thanks a lot!! it worked perfect for me, now i can see the messages in the terminal when they arrive

Darn, does not look as if AT+QURCCFG is a supported command for M95 :-1:

Happy it solved the others problem though. Direct communication through serial did not help either.