M66 mqtt cme 3518


I’m using Quectel M66 for MQTT data transfer. I’m getting response as +QMTPUB:0,1,0 and after that **CME Error: 3518 ** as response. I would like to know the reason for this error. As per the user manual, the error is invalid parameter, but I’ve verified the data is in JSON format.

My i know the reason and solution for this error.


That command should be the response for other command. You could share your full AT command log. So I can what casue error 3518.

Best Regards,

I’ve solved the issue by rewriting the certificates

1 Like

I am working on M66 module, even I am facing issue getting +CME Error 3518, how to solve this?

I have not enabled SSL.

Hi @anjalitalreja91,

Have you tried loading the certificates? and are you sure the MQTT server does not require any SSL? I received 3518 when there was issue in uploading certifcate.

were you able to solve the issue in normal mode? My PUB command is getting the same issue

Hi Athmesh:
Could you please share your full AT command log?

1 Like