M26 UART connection problem

Hi,

I am trying to get connected with Quectel M26 using UART connection. I am using a 2303HX usb-uart converter. My settings for serial connection are: 115200 baudrate, 8 data bits, no parity bit, no flow control. However, whenever I connect M26 to my PC the module does not accept any AT command. It just gets in a loop like;

[2020-07-09 19:39:43:568_R:] DSR:0 CTS:0 RI:0 (DCD:1)

[2020-07-09 19:39:43:569_R:] DSR:0 (CTS:1) RI:0 DCD:1

[2020-07-09 19:39:43:570_R:] (DSR:1) CTS:1 RI:0 DCD:1

[2020-07-09 19:39:43:570_R:] DSR:1 CTS:1 (RI:1) DCD:1
[2020-07-09 19:39:43:571_R:] AT

[2020-07-09 19:39:43:571_R:] OK
[2020-07-09 19:39:43:854_R:] ATE0

[2020-07-09 19:39:43:856_R:] OK
[2020-07-09 19:39:44:437_R:]
[2020-07-09 19:39:44:438_R:] OK
[2020-07-09 19:39:45:006_R:]
[2020-07-09 19:39:45:007_R:] OK
[2020-07-09 19:39:45:486_R:]
[2020-07-09 19:39:45:487_R:] OK
[2020-07-09 19:39:46:060_R:]
[2020-07-09 19:39:46:062_R:] OK
[2020-07-09 19:39:46:646_R:]
[2020-07-09 19:39:46:647_R:] OK
[2020-07-09 19:39:47:122_R:]
[2020-07-09 19:39:47:124_R:] +CME ERROR: 3517
[2020-07-09 19:39:47:706_R:]
[2020-07-09 19:39:47:708_R:] +CME ERROR: 3517
[2020-07-09 19:39:48:292_R:]
[2020-07-09 19:39:48:294_R:] +CME ERROR: 3517
[2020-07-09 19:39:48:778_R:]
[2020-07-09 19:39:48:780_R:] +CME ERROR: 3517
[2020-07-09 19:39:49:347_R:]
[2020-07-09 19:39:49:350_R:] +CME ERROR: 3517
[2020-07-09 19:39:49:930_R:]
[2020-07-09 19:39:49:933_R:] +CME ERROR: 3517
[2020-07-09 19:39:50:414_R:]
[2020-07-09 19:39:50:417_R:] +CME ERROR: 3517
[2020-07-09 19:39:50:995_R:]
[2020-07-09 19:39:50:998_R:] +CME ERROR: 3517
[2020-07-09 19:39:51:574_R:]
[2020-07-09 19:39:51:577_R:] +CME ERROR: 3517
[2020-07-09 19:39:52:053_R:]
[2020-07-09 19:39:52:057_R:] +CME ERROR: 3517
[2020-07-09 19:39:52:618_R:]
[2020-07-09 19:39:52:621_R:] +CME ERROR: 3517
[2020-07-09 19:39:53:201_R:]
[2020-07-09 19:39:53:205_R:] +CME ERROR: 3517
[2020-07-09 19:39:53:774_R:]
[2020-07-09 19:39:53:777_R:] +CME ERROR: 3517
[2020-07-09 19:39:54:254_R:]
[2020-07-09 19:39:54:257_R:] +CME ERROR: 3517
[2020-07-09 19:39:54:847_R:]
[2020-07-09 19:39:54:850_R:] OK
[2020-07-09 19:39:55:428_R:]
[2020-07-09 19:39:55:431_R:] +CREG: 0,0

[2020-07-09 19:39:55:436_R:] OK
[2020-07-09 19:39:55:907_R:]
[2020-07-09 19:39:55:910_R:] OK
[2020-07-09 19:39:56:487_R:]
[2020-07-09 19:39:56:491_R:] OK
[2020-07-09 19:39:57:058_R:]
[2020-07-09 19:39:57:061_R:] OK
[2020-07-09 19:39:57:543_R:]
[2020-07-09 19:39:57:546_R:] OK
[2020-07-09 19:39:58:129_R:]
[2020-07-09 19:39:58:131_R:] +CCLK: “04/06/24,01:48:34+00”

[2020-07-09 19:39:58:135_R:] OK
[2020-07-09 19:39:58:745_R:]
[2020-07-09 19:39:58:748_R:] +CSQ: 21,0

[2020-07-09 19:39:58:751_R:] OK
[2020-07-09 19:39:59:231_R:]
[2020-07-09 19:39:59:234_R:] +CCLK: “04/06/24,01:48:36+00”

[2020-07-09 19:39:59:237_R:] OK
[2020-07-09 19:39:59:705_R:]
[2020-07-09 19:39:59:709_R:] +CME ERROR: 3517
[2020-07-09 19:40:00:748_R:]
[2020-07-09 19:40:00:751_R:] +CME ERROR: 3517
[2020-07-09 19:40:01:323_R:]
[2020-07-09 19:40:01:326_R:] +CCLK: “04/06/24,01:48:38+00”

[2020-07-09 19:40:01:330_R:] OK
[2020-07-09 19:40:01:889_R:]
[2020-07-09 19:40:01:892_R:] +CREG: 0,0

[2020-07-09 19:40:01:895_R:] OK
[2020-07-09 19:40:02:941_R:]
[2020-07-09 19:40:02:944_R:] +CME ERROR: 10
[2020-07-09 19:40:03:517_R:]
[2020-07-09 19:40:03:520_R:] +CCLK: “04/06/24,01:48:40+00”

At the end “Normal Power Down” appears and all these messages are displayed over and over. My AT commands are not recognized. Now, I am stuck and I can not use the module. Could you help me with this issue?

Are you sure?
At the beginning of your log, I can see an “ATE0”, which switches off the echo of your commands. Without this echo, you simply can’t see, what you typing in.
After that, i see a lot of “OK” and error messages, which means, that your commands are received and proceeded.

Dear Andreas, thank you for your reply.

This M26 module is on a pcb of a security system and there is a microcontroller which controls M26. I think all these “OK and error messages” are replies to microcontroller commands OR there is some kind of monitoring software in M26 which keeps on running and posting these messages. I could not find a way to stop M26 posting these logs.

Thank you for your care to my problem.

I have the same problem. Please help. What is error 3517 for?

Module initializing
ATE1

OK

+CFUN: 1

+CPIN: NOT INSERTED
AT

OK
AT+CMGF=1

+CME ERROR: 3517
AT+CMGF=1

+CME ERROR: 3517
AT+CMGF=1

+CME ERROR: 3517
AT+CMGF=1

+CME ERROR: 3517
AT+CSCS=“GSM”

OK
AT+CMGS=“0090505000000”

please insert the SIM card and test it.

I put the SIM card in the board. That is, it is possible that the connection with the SIM card has been lost?

Hi
from your previous log it is clearly shown SIM card is not detected
image

please check the AT+CPIN? command response.

Merhaba
Quectelin sayfasında Toolkit kısımında indirebileceğiniz QCOM uygulamasıyla haberleşebilirsiniz.

Evet sadece Quectel sayfasında var. İstediyseniz, yakın zamanda size dönüş yaparlar diye umuyorum.