M10 GSM Module: SMS Receiving Problem at midnight

Hello everybody,

I’m writing here because I have a problem with my Quectel M10 module.
Further I figured out a problem in receiving SMS messages for one hour, exactly from midnight (00:00o’clock) till 01:00o’clock in the morning. After this hour the messages which were sent between that time span are received exact at 01:00o’clock. Lots of them, but not every message.

So my question is, do you know such a strange behavior from other users/projects? Or do you have any idea from which this behavior come from?

Another fact that i noticed was that the SMS I’m sending from my phone to the M10 has the correct time when i read the message (AT+CMGL=“REC UNREAD”). When i get a SMS message from another GSM module with the Quectel M10, i have a wrong time: Exactly one hour behind the real time.
That problem persists, no matter which time I set with the command AT+CCLK. Maybe something with my problem above, not receiving any SMS for one hour, hast to do with the wrong time on the M10?
(AT+QNITZ is not supported by my carrier. AT+CTZU=1 and AT+CTZR=1 has also no effect on the internal time of the M10. Nothing changed. Only set the time via AT+CCLK=… does work.)

Would be happy for any idea how i can solve the problem.
All the best, Thor

Dear Thor,
Thanks for your inquiry in Quectel forum.
Have you try to set AT+CTZU=3 to show local time and time zone ? I think the issue maybe the module reported time is not consistent with your phone time. So it is better to check the time firstly. And about the SMS issue, we have no other customer have meet such issue, please help to provide more information. Thanks!

1 Like

Hey Kyson,
Thank you for your answer! Yeah, i tried it few seconds ago, but the time did not changed.

For the problem with receiving any SMS during midnight and 1pm i found out that one of my carrier is guilty. Also different Sim-Cards from the same carrier have the same problem. It is Lycamobile from Austria.
With other carrier, the GSM Module works perfectly.

But the problem with setting the time (CCLK) through AT+CTZU persists - nothing changed.
I tried to change CFUN after the commands above (i read it saves the changes and is equal to do a restart) but the same time appeared.

I also tried the time-procedure from the Quectel UC20 - but i didn’t work.
Quectel UC20 Time Synchronization PDF

Hi Thor,
If that, the issue may come from the network, because the time is come from the base station. So if you can try to use NTP server to get the time to have a try ? Thanks!


image

1 Like

Hey Kyson,
Thanks for your reply!

Okay i understand. The standard time server was set. So i tried “AT+QNTP?” an the answer was the number 5 which means “Failed to activate PDP context”. So i tried to activate it via “AT+CGACT=1,1” because there are three entries (1,0 and 2,0 and 3,0). But it didn’t worked.
Also with a different time server it doesn’t work.

Best regards Thor

Dear Thor,
You can try the following command AT+QIACT to activate the PDP context. Thanks!
image

Dear Kyson,
Sadly it doesn’t work. I get an ERROR as an answer.
Thanks for the good idea!
Thor

Dear Thor,
If it return error when you use AT+QIACT command. How about to use AT+QIDEACT to deactivate PDP context firstly, then use AT+QIACT to activate again. Thanks!
image

1 Like

Dear Kyson,
AT+QIDEACT works but again the QIACT command sadly not. The M10 is a new chip, i have three of them. Every one of the three has the same Error.
Thanks! Thor
M10_4

Dear Thor,
If that, whether you have set APN with AT+QICSGP command before you activate the PDP with AT+QIACT. If not, cloud you follow up the following AT sequence to check again. Thanks!
ATI
AT+COPS?
AT+CSQ
AT+QIFGCNT=0
AT+QICSGP=1,“CMNET” //Set APN, here CMNET just an example, you should use the right APN of your SIM card that you used now.
AT+QIACT //if still failed, please go on the following steps
AT+QILOCIP
AT+QIDEACT

1 Like

Dear Kyson,
Thanks for your answer.
I tried everything, but i got an error again at AT+QIACT and AT+QILOCIP. The same answer i get with different M10 chips and two different providers/sim cards.
Thanks Thor

Hey Kyson, okay now it works! Perfectly!
I figured out that the answer of the command
12:36:55.590 -> AT+QIREGAPP?

Was empty in two fields:
12:36:55.590 -> +QIREGAPP: “bob.at”,"",""

So i filled in the missed data and suddenly the answer of AT+QIACT was OK.
The QNTP Server which works is time1.google.com
So i got the following grand answer:

12:41:53.402 -> AT+QNTP=“time1.google.com

12:41:53.436 -> OK
12:41:54.887 ->
12:41:54.887 -> +QNTP: 0
12:42:22.879 -> AT+CCLK?

12:42:22.879 -> +CCLK: “20/04/08,10:42:24+00”
12:42:22.912 ->
12:42:22.946 -> OK

And thats the correct time. Thank you very much for your help and time! That problem costs me a lot of days before i wrote here in the forum :slight_smile:

OK, Great. Thanks for your updating. You can go on use Quectel modules. If you have any other questions, you can just create topic here, we will help you to solve it. Thanks!

1 Like