LTE issue on Quectel EC25-E

I am trying to bring up LTE on NXP board with Quectel EC25-E on Android platform. We got Mobile network settings and Mobile data is enabled. Even ppp0 entry is added in ifconfig with a local ip address. Now if we try to ping any ip it comes as Network is unreachable. In Browser it shows ERR_NAME_NOT_RESOLVED. We even added dns server in /etc/resol.conf Still we are not able to get internet. We are using Jio Sim card. APN settings are also added. Near mobile network a cross mark is there. But in sim status data is connected.

Thanks for your inquiry.
When you use EC25 module with Android platform, whether you have install module’s Ril driver ? Please confirm it. For your issues, it is better to contact our local FAE to guide you how to install the RIL driver, and how to debug the issue. Thanks!

I have installed RIL driver. GPS is working fine. But no LTE, which configurations are required for LTE bringup?

Dear Sir,
Please follow up the following steps to modify your settings.

  1. set the default preferred network to 4G.
    The default preferred network of Android is 3G, but our module is 4G module, so we change the default setting of Android to 4G.
    Take Android 5.0 as an example:
  1. modify the Settings menu to display 4G options
    Settings->WIRELESS & NETWORKS -> More…->Mobile Networks-> set the preferred network…
    The corresponding is
    Modified file is packages/services/Telephony/res/values/config.xml
    set config_prefer_2g as true,default is true
    set config_enabled_lte as true,default is false

  2. the default preferred network is 4G
    Modfiy the file frameworks/base/telephony/java/com/android/internal/telephony/


  1. change to get the preferred network from the Settings instead of the fixed RILConstants.PREFERRED_NETWORK_MODE
    Part of the android code is already there, please double check.

Hi Sir,
Thank you for response. Can you tell me about the 3rd point, that part of android code is in which file?

Please check the following file. Thanks!



I got that part of code in frameworks/opt/telephony/src/java/com/android/internal/telephony/

Hello Sir,

I made all the changes suggested by you. But still I am not getting any internet. I am using Android 9.0. In preferred network LTE is there, in ifconfig ppp0 entry is present still If I try to ping dns address it says network is unreachable. You can notice that there is a cross mark near mobile network symbol and it is detecting JIO but if I click automatically select network then it says “No Network Found”

Dear Sir,
For such issue, please contact our local FAE to support you. It my need to catch debug log to analyze the root reason. Thanks!
If you do not know who can contact, you can send email to to get support from our local FAE. Thanks!

Ok Sir. Thanks for the imformation

Were you able to get it working?

Do you able to solve ?
I am also facing the same issue can you suggest the changes that you made?

Same here, any update on this issue?

Hi all,

This issue was resolved.
Mine was gateway issue. So after programming gateway to “” issue was resolved