LTE-A EG18 locking bands for Carrier Aggregation

Thu, Oct 27 • 00:10

issues locking bands LT18


I have issues locking bands for the carrier aggregation on my LT18.

I can’t lock this two bands B2+B66.
It seems to be two version for this modem probably for two specific regions, Modems that come with specific region can’t not be unlock for all bands?. I travel worldwide, so I need that to work with all global bands possible.

So I need a little help with the last part of the AT commands.

This is what I got when I type the command:


+QCFG: “band”,0x8d0,0x1a0080800d5,0x0


I have issues changing the bands with those HEX values.


Band B2 is HEX 2

Band B66 is HEX 20000000000000000

I am not sure if the correct value for the carrer aggregation of both of this bands will be type like this: 220000000000000000


Should I type ?


What options should I try?

Hope you can help me out here.

Thank you,


Quectels use 128-bit bandmasks. So you need a mask with bits 2 and 66 set.

You get that by doing a bitor of those two values. Hex addition also works, and gives the same result (as long as there are no duplicated values).



Note that the hex identifier “0x” is invalid syntax when used in the set version of the command.

So maybe this is the right one all correct type no spaces B2+B66 :


Nope this is not working to me, maybe I have to unblock the bands first?

Earlier, you gave your LTE bandmask as 0x1a0080800d5

I take it this is the default bandmask for your EG18.

If so, this is an EG18-EA, meant for the markets EMEA, APAC and Brazil.

LTE bandmask 0x1a0080800d5 decodes as the band list 1 3 5 7 8 20 28 38 40 41.

You should not be trying to enable band 2 or 66 on this modem. It is the wrong variant for that.

well It was the whole point of this, when I bought this modem I been advertised it was global