Long delays with BG96 receiving SMS messages

Hi all,

I’m using a BG96 on the Telstra 4GX network, and trying to use it to receive SMS messages, however there is a significant delay until the BG96 receives the message.

Has anyone else ever come across a similar issue before?

I’m not sure if its a configuration error or not, and I don’t even know the first place to look.
I was wondering if I could receive some assistance from anyone.

I’m not sure what information to include in this post, but i am using firmware version BG96MAR02A07M1G

These are the commands I use to start the modem.

21:11:22.507 → AT
21:11:22.676 → ATE0
21:11:22.815 → ATE0
21:11:22.946 → AT+QCFG=“band”
21:11:23.131 → AT+QCFG=“band”,0000000F,8000000
21:11:23.278 → AT+QCFG=“iotopmode”,0,1
21:11:23.432 → AT+QCFG=“nwscanseq”,02,1
21:11:23.563 → AT+QCFG=“nwscanmode”,3,1
21:11:23.695 → AT+CGSMS=2
21:11:23.880 → ATI
21:11:24.435 → AT+CPMS=“ME”,“ME”,“ME”
21:11:24.435 → AT+CEREG?
21:11:24.535 → AT+CMGF=1
21:11:24.582 → AT+CPMS?
21:11:24.636 → AT+CEREG?

Thanks

Do you get the delay when you send a self-addressed SMS?

Has the MSISDN (the “phone number” of the SIM) been ported from another carrier?

You might be able to check whether the problem follows the modem or the SIM, by using a different Telstra SIM with the modem.

An ordinary Telstra SIM will work with Cat M1 IoT, just not with Cat NB1 IoT.

Hi snowgum

Number has not been ported, its a new sim card from Boost, a subsidy of Telstra.

Self addressed text sms messages appear to come back more responsively with less of a delay.

Yep, using CATm1.

Will try another sim card shortly and report back.

Hi,

Have tried a new sim card, but with no change to the results.

I have however plugged in a band new BG96 modem that i had spare, and it seems to be working fine,

The last time I remember the original modem working was before I started experimenting with the power saving mode settings. I have tried to disable power saving mode, I’m wondering if i have put in some settings that are causing the modem to unregister itself from the network for certain periods of time……

Is there any difference in the results of this command between your two BG96 modems?

AT+CGDCONT?

I’m specifically interested in an entry with “ims” as the APN.

My BG96 seems to receive SMSs promptly (Aldi SIM - Telstra wholesale network), but I have context 2 set with “ims” as the APN.

I’m wondering if SMS delivery by NAS (as the fallback from IMS) has an issue with an IoT connection.

Hi There,

I’m not sure about the new modem bit of a mission to get that one plugged in, but the broken modem says this:

+CGDCONT: 1,“IPV4V6”,“”,“0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0”,0,0,0,0

You have no APNs set. To set yours the same as mine:

AT+CGDCONT=1,“IP”,“telstra.internet”
AT+CGDCONT=2,“IPV4V6”,“ims”

I think a likely cause of the SMS delivery delays is the fact the lack of the "telstra.internet" APN in context 1 will result in your BG96 being permanently flagged as absent (ie, it will not achieve normal network registration).

These settings will persist through resets and power-cycles until changed to something else.

To remove the context 2 APN again entirely, the command is AT+GCDCONT=2

Hi SnowGum,

Thanks for your reply, AT+CGDCONT=1,“IP”,“telstra.internet” (had to replace the double quotes “”" with plain ones in the cmd as this resulted in an error each time)

Just tried adding the first one (telstra) but it didn’t seem to have any effect in the delay of incoming messages unfortunately.