lock cell on RG502QEA

Hello,

I have a problem with the RG502ea modem. The point is, I’d like to let pci and earfcn in.

My modem and software version are:

ati
Quectel
RG502Q-EA
Revision: RG502QEAAAR11A03M4G

This is how the aggregation of bands looks like:

AT + QCAINFO

  • QCAINFO: “pcc”, 525.75, “LTE BAND 1”, 1.251, -110, -11, -78.13
  • QCAINFO: “scc”, 3350,100, “LTE BAND 7”, 1,251, -107, -10, -87.0
    DL
  • QCAINFO: “scc”, 1474.75, “LTE BAND 3”, 1.251, -98, -12, -76.0
    DL
  • QCAINFO: “scc”, 6275.25, “LTE BAND 20”, 1.251, -91, -9, -73.0
    DL

And now I choose cell lock:
at + qnwlock = “common / 4g”, 1.1474.75
OKAY
at + qnwlock = “common / 4g”

  • QNWLOCK: “common / 4g”, 1.1474.75

that is, as I understand it, the command worked. But now I take:
AT + qnwinfo

  • QNWINFO: “WCDMA”, “26006”, “WCDMA_VIII_900”, 2938

The modem, instead of connecting to LTE technology, drops to 3G.

What’s the problem. I have old firmware or what?

Well, yes you have old firmware to begin with.
and you are doing the command wrong.So it might happen.
Also, BTS can allow you to connect to a specific band as primary, but not always, so it drop to 3g, because you have it enabled, if you disable it, you woud see it woud drop connection altogheter.
on QCAINFO you can see earfcn and pcid.
at + qnwlock = “common / 4g”, 1.1474.75 is wrong sintax, and also wrong PCID, of course it doesnt work, 1475 is earfcn for band 3, so you want to lock band 3 on your BTS, but 75 is not the pci you are connected. 251 is the PCI of your connected BTS cell, so you would need to do:
AT+QNWLOCK=“common/4g”,1,1474,251
Now you would lock to your BTS band 3.
Still, your firmware is very old anyway.

I’ll try it tonight. I just knew about the comma instead of the dots, the text was not copied correctly on the forum. I’m sorry. In fact, I did not fully understand the particular data for this command. Thank you very much for your leave. I will test

@ sitel did you make a mistake with the earfcen shouldn’t be 1474 instead of 1475? Where is 1475 in qcainfo, if it is calculated somehow?

yep, my bad, corrected.

Is it possible to save the lock cell somewhere in the modem’s memory so that it will remember this setting after restarting? At the moment, whenever I type the command after rebooting:

at + qnwlock = “common / 4g”

it shows me

at + qnwlock = “common / 4g”, 0 which means it returns to the default value

nope it reset every reboot of the modem. it can be done by script, or you can just use ROOter if you are on openwrt, and it have cell lock.

What is ROOter package or what?

Just a custom version of OpenWrt for modems.
ROOter site
Download Latest version Site

Stiel could you wirte me what the correct lock cell syntax looks like for RG502QEAAAR11A07M4G. Can you give an example?

EDIT:

Ok, I have found the solution myself. This is some kind of drama that the producer doesn’t write how to use it specifically. No information about it at all in the instructions for this modem. Nothing regarding AT + QNWLOCK nothing 0. Producer correct yourself. Many people buy a modem for this feature and then have to look for solutions in forums. Drama