LC86G-LA position problem


I’m currently having trouble with my LC86G-LA. I updated my pcb with this GNSS instead of a L80-R (No problem with it).
I’m having trouble with the position and speed wich are wrong

I tried different constalletion configuration (Default and GPS+GALILEO) with no result.

Th e only parameter i change to the default configuration is the refresh rate i set to 10HZ

Any idea why the speed and position are wrong ?



I made more test, according to the log, the problem appear when the Z acceleration start to reach to 2G and speed at 200km/h.

I am using the GPS on a RC Plane with a max speed of 400km/h and G -4 to +8G, i have no having this problem with the L80-R.

According to the documentation of the LC86G have different mode of NAVIGATION

We can change with PAIR080 command :
Navigation mode.
0 = Normal mode. For general purposes.
1 = Fitness mode. Used for running and walking purposes, making low-speed movement (< 5 m/s) more impactful on position calculation.
2 = Reserved.
3 = Balloon mode. Used for high-altitude balloon scenario where the vertical movement has a greater impact on the position calculation.
4 = Stationary mode. Used for stationary applications where a zero-dynamic is assumed.
5 = Drone mode. Used for drone applications with equivalent dynamic range and vertical acceleration at different flight phases (for example, hovering and cruising).
6 = Reserved.
7 = Swimming mode. Used for swimming activities to smooth the Field Format Unit Description

I’m going to try the Drone Mode



Hi Julien,

Please query the firmware you currently use by sending $PQTMERNO*58 to the module.

  1. You mentioned that the position and speed are wrong when device reach a high speed. Did LC86G output wrong/inaccurate position or the module lost fixed?

  2. What’s the environment when you testing with RC plane? Is it open sky?

  3. Can you share me the logs from LC86G when doing high speed moving?

Best regards.

Hi Raphael,

There is not lost fixed the problem occured when the Z acceleration start to reach 2 - 2.5G.

The test are made in a RC Plane with open sky, We have two GPS system in the plane.

The first One (Not Quectel) is our reference GPS (GPS, Galieo, Glonass) => We have same result with a Quectel L80R

The Second is the Quectel LC86G (Default constellation, GPS, Galieo, Glonass, Beidou, QZSS) => Our new card in replacement of the L80R

Here the track comparaison on the same fligth between the two GPS

Reference GPS


Here the files with the log of the flight, There is the latitude, longitude, speed and satellite for the both system. I also insert the Z acceleration and a comparaison value of data.
It’s a excel file

You can see the huge difference between the two system on time :

  • 00:03:03 to 00:03:04
  • 00:03:29 to 00:03:39 => 180Km/h difference + Latitude, Longitude Diff
  • 00:04:00 to 00:04:12 => 135Km/h difference + Latitude, Longitude Diff
  • 00:04:36 to 00:05:01 => 222Km/h difference + Latitude, Longitude Diff
  • 00:05:22 to 00:05:34 => 207Km/h difference + Latitude, Longitude Diff

I didn’t have this difference between the Reference GPS and the L80R, the problem only occured when i swapped to LC86G

For the firmware the command $PQTMERNO*58 return nothing


Hi Julien,

Sorry for my previous mistake. The firmware query command is $PQTMVERNO*58.

Did you make any configurations to LC86G?

Unfortunately, as an industrial grade module, we didn’t consider such extreme scenario. And our instrument can cover only 5g accelerated velocity.

My suggestion: 1. set all constellation enabled:$PAIR066,1,1,1,1,1,0*3B;
2. set Drone mode

Best regards


I just tested the Drone Mode and the result are a disaster.

I’m loosing all satellite at 1.5G

I don’t understand why there is huge difference between the L80-R and the LC86G.

Is there a solution to make le LC86G working properly ?

The L80R is better for now


Hi Julien,

As an industrial module, we didn’t pay much attention on high speed/acceleration performance. We will try to inprove the performance. I will send you the latest firmware for LC86G(LA) via message.

Best regards

Hi Raphael.

I also need the update to the LC86. The L80 works perfectly well on my board, but the LC86 is terrible performance - inconsistent GPS fix. Tried improving it by changing the ground plane, but no success there. L80 works fine.

Hi Raphael,

I did the update and after few test the new firmware seems to have corrected the position problem. Is there a way tu upgrade the GNSS Module without using the Quectel software ? By C programm using serial communication ???


Hi Mascle,

I will send you a reference program via message.

Best regards.

Hi Daniecreox,

please reach out to to get firmware, thanks~

Best regards.