LC79D Date error on GNRMC


I am working with the LC79D GNSS module and I have a date error on the GNRMC frames.

This problem came somewhere between 19/08/2022 and 21/08/2022 as I was having the correct date earlier on.

The expected date of the day is 24/08/2022 while I am receiving 08/01/2003. Here is an example of a frame I receive.


The bug is software related as I can reproduce it on different boards. Also, sometimes when I do a hard reset, I get the correct date without changing the way I use the module.

Do you have any idea where it comes from? And how can I correct this?

Thank you

I figured that you would need the firmware information so here is what I get when I power up the module:


I tested again today (01/09/2022) and the date I get from the GNRMC frames is the 16/01/2003

The LC79 seems to keep a good track of the date but with a wrong reference/stating point.

It looks like a firmware error of the LC79, so I would like to know if there is a way to fix it?

Thank you


I looked a bit more in the topic and i found that in the nmea protocol the date is subject to a rollover of a week counter. This rollover is due to the fact that the weeks are counted on a 10 bits counter wich represents about 19.6 years wich corresponds to the time shift that we observe.

Link of the article where i found the information : NMEA Revealed

Is there a way to patch the firmware of the LC79 to avoid this rollover ?

Also I might open a new ticket under the GNSS section as I did not found how to change the question label or add one

Thank you for your time reading me


Hi Augstin,

Sorry for the delay. GPS week number rollover is recently reported internal. Here are solutions.

  1. Upgrade Firmware
    The latest firmware version has the most recent GPS week number rollover compensation value. Thus, updating the firmware of a receiver can postpone the occurrence of the week number rollover. Since the week number rollover period is 19.7 years, it is recommended to update the firmware before the week number rollover occurs.

  2. Disable GPS
    When the receiver calculates a wrong date, for the multi-GNSS receiver, other GNSS (except GPS) constellations cannot participate in positioning because the time from messages of other satellites cannot synchronize with GPS time, which means only GPS works for positioning.

    Only GPS has such week number rollover issue, so you can disable GPS for the multi-GNSS receiver, but the performance may be decreased.

  3. Adjust Host-side Date
    Another solution to the GPS week number rollover issue is to add a compensation algorithm to the client application running on the host processor. The algorithm takes the wrong date from the receiver and converts it to the correct date before passing it further up the application stack. Just to add 1024*7 days to the 10-bit week number to get the actual GPS week number.

Please note that it’s a temporary solution and cannot completely avoid the week rollover issue.

Best regards.


Thank you for your answer,

Once we understood that the problem came from the week count rollover we implemented the 3rd solution you proposed. I just wanted to be sure it was really the origin that to avoid further bugs in the application if the date error wasn’t constant

Thanks again
Best regards,


I am opening the topic because I am constating a new issue that seems to be related:

The date I get from the LC79D is one day ahead of the current date (the hour and minutes is correct)

Do you have any idea where this may come from? The product has worked with the correct date for a few months now and this issue is a few days old

Thank you by advance


I am open to update the firmware of the chip, if so, could you provide me with the latest firmware
My actual firmware version is the following

I have found a GNSS flash tool V1.9 to update. Is it also the latest version ?
Thank you,
Best regards,

I set up my mind on a update,
Could you provide me with the latest version ?

Thank you by advance
Best Regards,

Hi Augustin,

I will send you latest firmware via message.

Best regards.

The firmware version provided solved the problem,
Thank you ,