Latest firmware for EC20F

Hi

Where can I find the latest firmware for my 4G module EC20F, revision: EC20CEFAGR06A10M4G ?

We have more than 2000 EC20 operating in the field. However, lately, two of them stopped operating, with following log message:
Jul 5 16:25:03 sss pppd[1027]: Using interface ppp0
Jul 5 16:25:03 sss pppd[1027]: Connect: ppp0 <–> /dev/modemPPP
Jul 5 16:25:04 sss pppd[1027]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x1649bf73> ]
Jul 5 16:25:04 sss pppd[1027]: rcvd [LCP ConfReq id=0x9 <asyncmap 0x0> <magic 0xd114c71c> ]
Jul 5 16:25:04 sss pppd[1027]: No auth is possible
Jul 5 16:25:04 sss pppd[1027]: sent [LCP ConfRej id=0x9 ]
Jul 5 16:25:04 sss pppd[1027]: rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x1649bf73> ]
Jul 5 16:25:04 sss pppd[1027]: rcvd [LCP ConfReq id=0xa <asyncmap 0x0> <magic 0xd114c71c> ]
Jul 5 16:25:04 sss pppd[1027]: sent [LCP ConfAck id=0xa <asyncmap 0x0> <magic 0xd114c71c> ]
Jul 5 16:25:04 sss pppd[1027]: sent [LCP EchoReq id=0x0 magic=0x1649bf73]
Jul 5 16:25:04 sss pppd[1027]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Jul 5 16:25:04 sss pppd[1027]: rcvd [LCP DiscReq id=0xb magic=0xd114c71c]
Jul 5 16:25:04 sss pppd[1027]: rcvd [LCP EchoRep id=0x0 magic=0xd114c71c 16 49 bf 73]
Jul 5 16:25:07 sss pppd[1027]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Jul 5 16:25:10 sss pppd[1027]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Jul 5 16:25:13 sss pppd[1027]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Jul 5 16:25:16 sss pppd[1027]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
s-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Jul 5 16:25:22 sss pppd[1027]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Jul 5 16:25:25 sss pppd[1027]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Jul 5 16:25:28 sss pppd[1027]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Jul 5 16:25:31 sss pppd[1027]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Jul 5 16:25:34 sss pppd[1027]: sent [LCP EchoReq id=0x1 magic=0x1649bf73]
Jul 5 16:25:34 sss pppd[1027]: IPCP: timeout sending Config-Requests

It seems pppd failed to receive the dns IP address from the modem. I don’t know what happened to those modules, maybe a firmware update can solve the problem?

HI
I will email you the latest version, thank you.