L80-M39 change Baud to 38400


I am trying to change the Baud to 38400 as suggested in L80_Protocal.pdf but it seems to be ignored.

Power up L80-M39
Waiting 3-4 seconds doing other things
Send “$PMTK251,38400*27”, 13, 10 (9600)
But module is still sending NMEA at 9600?

Does anyone know what I am doing wrong?


Dear LeeM
Send “$PMTK251,38400*27” command need to add carriage return and line feed.


I cycled the power and now it’s changed.

Does it still only send 1Hz at 38400?

I’m trying to get it to output much faster.

Dear LeeM
The configuration is not lost when the power is turned off, please use the following command: $PQBAUD,W,38400*7B.


The command $PQBAUD,W,384007B is really durable after power OFF. Is there a similar
command for durable working like the command:$PMTK314,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
I need a small NMEA set with only $GPRMC. The $PMTK314 is only working while power ON.
Thank you for help