L76-LB No Communication

I have an L76-LB GNSS module connected to an ESP32.
I configured it with:


I am not able to establish a connection to a satellite. I have tried it on 2 separate modules, and also outdoor testing. Still, no luck establishing a connection. My wiring is correct, I am getting responses from the sensor, just not any meaningful ones.

What have I missed (any more PMTK configuration commands)?
Thanks in advance.

Dear josephsv
Please use this command to check the firmware version: $PQVERNO,R*3F, you need to add carriage return and line feed. Thank you!

Dear josephsv
L76-LB doesn’t support GALILEO,is GALILEO required?Thank you!

Hey @Albert.Liu-Q,
First off, thanks for the quick reply:)

I tried sending the sending this command and got the following output;

It doesn’t look like any version number; I have to check my code and see if I missed anything. (Also I did add the carriage return and newline; in Arduino with “\r\n”).

I did not know about the Galileo part, I assumed that it was also accessible, but thanks for bringing it to notice.

I still don’t seem to get any response from the sensor (empty fields). Do you think I should just try and update the firmware. If so, how would you suggest I do that?

Thanks in advance

Dear josephsv
Do you use the GNSS module to output NMEA sentences through the serial port?

For better support, you can send your company’s information and project status to my e-mail address, and I can contact the corresponding FAE to better support you.


I am using the standard UART port to communicate with the GNSS Sensor.
I am able to send and receive information.

Dear josephsv
Please use this command to check the firmware version: $PQVERNO,R*3F. Thank you!

I got the following output when checking the firmware version using $PQVERNO,R*3F


Do I have to update to a different firmware version?

Dear josephsv
Currently all firmware versions of L76-LB do not support Galileo, thank you!

Dear @Albert.Liu-Q,

Thank you.
I do not require Galileo support. I got the above response when sending the PMTK command ($PQVERNO,R*3F). I am still not able to connect to any satellite.
Are there any further checks I can do to confirm this is a hardware issue?

Thanks again:)

Dear josephsv

  1. You can check whether the antenna link is normal by yourself;
  2. You can also send me the log of NMEA sentences output by GNSS, as long as possible.
  3. You can also send me the GNSS schematic diagram and the antenna specification, let me check it;
    Thank you!

Hey Albert,

I finally managed to get the sensor working. I also got a satellite lock.
But now, I would like to improve the range. Any suggestions on how to improve indoor performance?

Thanks again:)

Hi Sir
Because indoor GNSS signals are generally weak, positioning will be more difficult. What kind of application do you need indoor positioning? Do you use other positioning methods? Such as Bluetooth and wifi positioning?