L76-L NMEA delay 5-6seconds


I am using a L76-L on Pytrack to track a location. I am looking for a location update every second. I am getting enough messages to update every second, but the NMEA messages are already delayed by 5-6 seconds when read from the I2C bus. I have tried many many different configurations, e.g. upping the baudrate, using only GPS or GPS+GLONASS. The delay was always the same.
E.g. i get an RMC message with timestamp 12:02:30 and the actual time is already 35 seconds. I have tested this in the field and the timestamps are correct for the coordinates, but 5-6 seconds old.

Many thanks

Hi Imtho,
Please try to connect wires to the module, in order to read NMEA message directly form the module’s UART port. And adding timestamp( both I2C and UART ) for comparison. This operation aims to find out whether the module itself is faulted or not.

Please provide the firmware version by sending command : $PQVERNO,R3F
you will get response like:

Best regards.

Hi, I tried it with 3 different pytracks/Quectel modules, but unfortunately I cannot do the comparison of UART/I2C at the moment.
Might it be connected with the DGPS modes? I noticed that the delay seems to be longer when a lot of movement (aprupt changes) or fast movement is happening.
Also the Buffer seems to be huge, when I read out the buffer I get very old timestamps. > than 40 seconds old. But even with fast enough buffer emptying and reducing the messages to only RMC I get a delay of 1-6 seconds.

That would be $PQVERNO,R,L76LNR02A01SC,2018/07/23,08:35*65

Hi Imtho,
Please try to upgrade the latest f/m version, and check whether delay extinct or not.
Best regards.
L76LNR03A01S.zip (2.0 MB)