L76 GNSS not responding to UART commands

I have a Quectel L76K GNSS chip connected via UART to my controller. After succesfully initializing the GNSS chip I’m to receive information over the UART. However, when I try to send any command to the GNSS chip, it doesn’t react to them (I neither received and acknowledge nor the chip does what is suppoused to).
I’ve also tried to send commands through my PC (just to discard the possibility that the baudrate in my system is not accurate enough), but so far no success. I receive information from the GNSS module, but when I send commands the GNSS module doesn’t react to any.

Does anybody has a suggestion?

I solved the problem.
It turns out that the Quectel L76K doesn’t provide an answer to commands ever. My mistake was to assume that the L76K was compatible with the rest of the L76 family, but it doesn’t. You have to find the specific documentation for the L76K. Otherwise you will break your head trying to figure out why the chip doesn’t react to your queries

Here some links with the proper documentation: