L70 GPS module No communication

We are using RAK8211 IOT Board by rakwireless on which the host controller is nrf52832 connected to BC95 AND L70 GPS module.

Configuring the UART of nrf for BC95 to communicate with at commands works without any flaw. But when same is done to communicate with L70 GPS module, there is no reply. not even a single junck character is received.

In the schematic of rak8211 the L70 Module is connected as follows:

txd--------------some pin on nrf
rxd--------------some pin on nrf
standby--------some pin on nrf
reset------------some pin on nrf

1pps not connected to nrf

vcc of L70 is connected to a switch IC which is same ic used for switching BC95 MODULE.
Configuring pins and enabling that ic to switch on the bc95 module worked and I can communicate the bc95 module with nrf .

if i do the same for L70, nothing is received, neither junk characters/garbage values.
I tried all the configuration. eg- not using or configuring STANDBY PIN, RESET PIN, TOGGLING THESE PINS AND WHAT NOT, Still there is nothing i receive from the L70 GPS MODULE.

As I dont receive anything I recon it must be an issue with switching on or something related to it.
I also tried all of the baud rate. default is 9600.
Can anyone give me a pointer or an idea how to proceed with this?


Dear Aman,
If the following methods do not work, please send e-mail to support@quectel.com for local FAE’s support.
Try the following methods sequentially.
1, Please refer to the attached doc and confirm the pin descriptions of L70 module.
When the RESET pin or the TIMER pin connect to GND, the L70 doesn’t output. Make sure that this situation didn’t happen on your board.
Download address:

2, Try to supply 3.3v power to L70 module separately and connect its TXD pin to PC via serial converter. Normally, you can receive data via serial tools with baud rate 9600 bps.